WordPress.org

Ready to get started?Download WordPress

Forums

Re-directed to wrong page when comment button clicked (15 posts)

  1. CaliforniaforThompson
    Member
    Posted 7 years ago #

    Morning Everyone,

    We are having a problem on our blog that is quite vexing, any input or help will be very much appreciated.

    Here is the problem:

    On our main website, we have a link to “Blog”, that link then takes you to our wordpress blog.

    The issue is with the comments, up until last week, when a user clicked on the link to comment on a post, the link took them to the comment form.

    Now, for some reason, when you click on the comment link, you are re-directed back to the “our staff” page on our website.

    I have the feeling that a link was switched somehow in the code governing the comments.

    How can I correct this so that when people click to comment it takes them to the make a comment page?

    Thank you in advance.

  2. tsguitar
    Member
    Posted 7 years ago #

    Here's what your links are like currently:
    http://californiaforthompson.com/wordpress/?p=16

    If you change that to:
    http://californiaforthompson.com/wordpress/index.php?p=16

    things work fine. I suspect it's your permalink structure: Admin >> Options >> Permalinks. I don't know who was in there messing around. When users click on the title of an entry on your blog, that leads to the "Our Staff" page, too. Can you take a look at that and see if anything jumps out at you? If you can post your Main Index Template (Presentation >> Theme Editor >> Main Index Template) to a pastebin, that will help figure out anything else.

    P.S. OOOOOO! Nevermind that! I think it's because you have an index.html page in that same directory and your site is set to load index.html before index.php. If you can change that, or even just change index.html to index1.html for testing purposed, that will tell a lot.

  3. CaliforniaforThompson
    Member
    Posted 7 years ago #

    Thank you for responding! one problem, when i go into the site admin from the link on the right hand side of the page, and go to options, there is no tab for permalinks.

    all that comes up is All in One SEO.

    Any suggestions?

  4. tsguitar
    Member
    Posted 7 years ago #

    Are you the only account on your blog? Maybe your account isn't an admin account. Is anyone else managing the blog for you?

  5. CaliforniaforThompson
    Member
    Posted 7 years ago #

    I am supposed to have admin rights for our blog account. the creator of the blog is our technology coordinator, and he had admin acces on his account.

    It sounds to me like i need to call him and have him correct the permissions. look s like my account flag is only moderator.

    I am going to need full access to the code to fix any of this

  6. tsguitar
    Member
    Posted 7 years ago #

    You might not. I really think your trouble is that your site is loading index.html before it loads index.php. Can you get rid of index.html inside your wordpress directory? Or just change the name of that file?

    I amended my first suggestion; it's not your permalink structure so much as your file structure. Your site needs to load index.php first. Your tech coordinator needs to change .htaccess to make that so.

  7. CaliforniaforThompson
    Member
    Posted 7 years ago #

    Okay, I now have my administrator access on the blog.

    where in the admin menu do i go to access the wordpress directory and the .htaccess files?

  8. moshu
    Member
    Posted 7 years ago #

    where in the admin menu do i go to access the wordpress directory and the .htaccess files?

    You don't. That's not a WP file. That's site administration. You use FTP.

    Alltogether is a dumb idea to have index.html and index.php in the same directory. The "technology coordinator" should know better than that...
    Restructure the site and REMOVE the index.html.

  9. CaliforniaforThompson
    Member
    Posted 7 years ago #

    Thanks for the info. we have a supported host and you have to submit a support ticket. Grrr...i am used to doing things by FTP.

    I have never worked with wordpress, or blogging programs. gaming servers, websites, forums yes...wordpress no.

    so forgive my noobness if you could :)

    I am waiting to hear back if the web host will give me access to the files or if they are going to want to do it themselves.

  10. moshu
    Member
    Posted 7 years ago #

    You don't need anything from the host. Just delete that index.html file from the wordpress directory and you are fine.
    (of course, make a backup copy, i.e. download it before proceeding)

  11. CaliforniaforThompson
    Member
    Posted 7 years ago #

    Yes, but in order to get to the wordpress directory...i have to have access to the server files that our wordpress blog is hosted on if i am understanding this correctly.

    Or do i have the wrong idea here?

  12. moshu
    Member
    Posted 7 years ago #

    Quote from you:
    am used to doing things by FTP.

    What else do you need?

  13. CaliforniaforThompson
    Member
    Posted 7 years ago #

    I was informed we do not have FTP access to the server our wordpress blog is hosted on.

    Here is the text of the email i received after emailing earlier asking for the FTP access info.

    "Our server is a supported server, so we have to submit a ticket. If we go
    in and mess something up they won't fix it later. Standby, I'll be back
    with you in a moment.
    "

  14. moshu
    Member
    Posted 7 years ago #

    Well, I never heard of anything like that... but if it works for you, that's fine.
    And if you don't have access to your own server - then don't ask for DIY solutions :)

  15. CaliforniaforThompson
    Member
    Posted 7 years ago #

    Okay, problem is resolved.

    Our tech guy was admining all this through dreamweaver. i had him go in through there and delete the index.html file

    everything works just fine now. thank you for your assistance and your patience!

Topic Closed

This topic has been closed to new replies.

About this Topic