WordPress.org

Ready to get started?Download WordPress

Forums

Weaver II
[resolved] re-direct loop with nextgen gallery & weaver II (5 posts)

  1. carriage stone
    Member
    Posted 4 months ago #

    I recently updated the nextgen gallery plugin to their .58 release and started getting redirect loops. When I disable the plugin, the redirect loops cease.

    However, if I try previewing my site under the twenty-fourteen theme with the gallery plugin activated, I also don't see the redirects, so it seems to be some interaction.

    wordpress.org/support/topic/nextgen-2057-got-posts-in-a-redirect-loops

  2. carriage stone
    Member
    Posted 4 months ago #

    I just updated to the latest version (2.1.4 from 2.1.1) in hopes of solving that problem. My previous problem with the nextgen gallery plugin remains and I am seeing another problem.

    For a while, I have had sidebar "text" widgets with the following content:

    [weaver_show_posts cats='Education' show_featured_image='1' show='excerpt' number='5' hide_top_info='1' hide_bottom_info='1']

    which have worked properly. Now I see just the command instead of the list of posts.

    I tried replacing the single quotes with double quotes (like I see in your documentation) and have tried adding spaces outside the square brackets, but have had no success.

  3. scrambler
    Member
    Posted 4 months ago #

    Regarding next gen interaction you need to post in the Weaver forum, providing a list to the site and detail error messages.
    http://forum.weavertheme.com/

    Regarding your shortcode, you may have noticed a banner after you did the last update telling you that you should install the Weaver Theme extra plugin.
    This is because due to new WordPress restriction, all the shortcode had to be moved into a plugin. So install the plugin and all should be well again.

  4. carriage stone
    Member
    Posted 4 months ago #

    Thanks. Installing the Weaver II plugin solved the shortcode problem as you expected. I had seen the banner advertising the plugin, but didn't want to risk having anything else break :-)

  5. carriage stone
    Member
    Posted 4 months ago #

    In the spirit of https://xkcd.com/979/, here's how I addressed the issue on my site...

    I have Yahoo hosting, so I don't have access to a .htaccess file to play around with.

    After experimenting unsuccessfully with lots of options I saw a posting on wordpress.org talking about redirect loops in relation to permalinks. I disabled permalinks and the site now works with both Weaver II and nextgen galleries. The URLs are ugly, but that isn't really a big concern for this site.

Reply

You must log in to post.

About this Theme

About this Topic

Tags