WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] RC3 Converting special characters (6 posts)

  1. nickobec
    Member
    Posted 8 years ago #

    If in a post I write — the first time the post is saved it is converted to — the next time it is saved it is converted to an em-dash (unicode value —)

    I find it annoying because I tend to blog on HTML and coding and my posts change each time I save them.

    It does not matter if it is wrapped in a pre or code element.

    I would just like to know how to turn it off. Because it is the only thing stopping me from using WP 2.0

  2. mattman
    Member
    Posted 8 years ago #

    Hi Nick, I'll assume your using TinyMCE which is the default editor when you installed RC3.

    You can disable the RTE (rich text editor) from the profile section for you account.

    Give that a try...Hope it helps!

  3. nickobec
    Member
    Posted 8 years ago #

    It is not TinyMCE, I was using the standard editor (the only editor available) with Safari on a Mac.

    Also my original post here should of read:

    If in a post I write — the first time the post is saved it is converted to — the next time it is saved it is converted to an em-dash &#8212 (unicode value —)

    I wrote — and thas was converted to — I assume because the support forum is using the same engine as WordPress 2.0 RC3

    Quick test
    If in a post I write — the first time the post is saved it is converted to — the next time it is saved it is converted to an em-dash &#8212 (unicode value —)

  4. nickobec
    Member
    Posted 8 years ago #

    Looks like I have a partial solution by using the backticks
    If in a post I write — the first time the post is saved it is converted to — the next time it is saved it is converted to an em-dash &#8212 (unicode value —)
    Little unsure about using the < code > tag seeing that got converted into two backticks
    Time to go test it on my blog

  5. nickobec
    Member
    Posted 8 years ago #

    Failure, the backtick solution works here but not with WP 2.0 RC3

  6. nickobec
    Member
    Posted 8 years ago #

    Finally worked it out well at least for the WP 2.0 release.

    You need to turn off the rich text editor and the automatically correcting HTML option in the profile section and make sure you select apply.

    In Safari 1.3 you get no visual clues as to whether the rich text editor is on or off. So check in another browser. But turning off those two options resolves my problem.

Topic Closed

This topic has been closed to new replies.

About this Topic