WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] RC2 - xmlrpc dropping post content (multisite only) (2 posts)

  1. scottroberts
    Member
    Posted 2 years ago #

    Reproduced on 3.2.1 and 3.3

    When I setup my WP main host, I can post something like this to the blog:
    http://vncaudio.com/2011/12/09/test-single-site/ (3.2.1, nginx)
    http://ksstorm.com/2011/12/09/wp-3-3-single-site/ (3.3RC2, apache -- same behavior under 3.2.1, apache)

    The 1pixelout javascript player is being added for the audio clips as it should.

    However, after I enable multi-site, the posts look like this:

    http://vncaudio.com/2011/12/09/test-after-multi-site-enable/
    http://ksstorm.com/2011/12/09/wp-3-3-after-multisite-enable/

    The <OBJECT> tag and its contents have been dropped....missing from the database, as well. Adding the multisite xmlrpc plugin does not change it -- the OBJECT tag is still dropped.

    http://vncaudio.com/2011/12/09/with-multisite-xml-rpc-add-in/

    In each case this is a fresh install with no plugins enabled, twentyeleven theme. Running on Debian Squeeze.

    3.3RC1 is on PHP 5.3.2-1ubuntu4.10 with Suhosin-Patch, mysql Ver 14.14 Distrib 5.1.41, for debian-linux-gnu (x86_64) using readline 6.1, apache 2.2.14-5ubuntu8.7

    3.2.1 is on PHP 5.3.8-1~dotdeb.2 with Suhosin-Patch, mysql Ver 14.14 Distrib 5.5.18, for debian-linux-gnu (x86_64) using EditLine wrapper, 1.0.10-1~dotdeb.1

    (Cross-posted in the multisite forum area)

  2. scottroberts
    Member
    Posted 2 years ago #

    Discovered after Googling more on the subject (I'd been working on it for a couple of hours by the time I posted) that the behavior is intentional. Sorry for cluttering the forum. Also found out how to make it happen if/when needed.

Topic Closed

This topic has been closed to new replies.

About this Topic