WordPress.org

Ready to get started?Download WordPress

Forums

Ranker List Widget
[resolved] Ranker plugin (10 posts)

  1. jimflege
    Member
    Posted 10 months ago #

    I've been tryin gto install this all day, and can't figure it out. Has someone been successful? What are the steps, in detail? How do you install from the plugins menu of WordPress?

    http://wordpress.org/plugins/ranker-list-widget/

  2. paulranker
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Jimflege,

    Hold tight, we're about to launch an update to our plugin. We've reworked the widget and plugin code from the ground up to bring you 2.0. You should see the new plugin in the directory this afternoon (10/15).

    Here are the steps for installing the widget via the admin UI:
    1) Go to Plugins > Add New
    2) Search for "Ranker List Widget" and click the Install link.
    3) Once installed change any settings you'd like via the Settings > Ranker Options window.
    4) From the Ranker Options click > Shortcodes at the top of the page. Here enter any Ranker List you'd like to embed from our main site.
    5) Once you have a shortcode created add that to a post and you're done!

  3. paulranker
    Member
    Plugin Author

    Posted 10 months ago #

    Plugin Version 2 is now released and ready for use. Thank you for your support!

  4. jimflege
    Member
    Posted 10 months ago #

    Paul,
    thanks very much for your prompt and detailed response. I'm honored by such special attention.

    I followed all the steps you listed as carefully as possible. I pasted the "shortcodes" generated by your Version 2.0 into a post on my WordPress blog, but instead of seeing the actual ranker list (as I did when I embedded html code into a box on a page of my website) I saw the shortcode on the published post. It at least contains a link that goes to the list on the Ranker site, but the list can't be seen right there in the Blog.

    here's the blogpage in question:

    http://travlearning.wordpress.com/2013/10/16/defining-the-best-slowtrav-towns-in-europe/

    and here's the website page where the ranker list appears in what I think is the "correct" (directly viewable) format.

    http://travlearning.net/study_centers.html

    Can you tell me what I'm doing wrong? Maybe I have to create a container into which to put the shortcode on my WordPress post?

    Thanks

    Jim Flege

  5. paulranker
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Jim,

    Can you try changing the name in the shortcode from:
    Defining the Best "Slowtrav" Towns in Europe
    to:
    Defining the Best Slowtrav Towns in Europe

    I think those extra double quotes maybe causing an issue.

    Thanks
    Paul

  6. paulranker
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Jim,

    I've just tested a short code with additional double quotes and while it does break the name displayed the widget should still be working. I'm going to patch the quote issue soon.

    Can you double check the plugin is still activated please? The plugin needs to be running to process short codes.

    Thanks,
    Paul

  7. jimflege
    Member
    Posted 10 months ago #

    Thank you, Paul.

    I checked and the Ranker plugin is indeed active on the host server (Yahoo Small Business). It took me a long time to figure out that I have to go the Yahoo Small Business control panel in order to access my WordPress administrative pages.

    Thanks, too, for addressing the "double quotes" issue. It's quite a tiny problem but, nonetheless, has a certain amount of significance.

    I wished to use the term "slowtrav" with quotes because it is not yet a well known term. It is short for "slow travel", which in turn represents a small niche in the travel industry that, I suspect, will grown in popularity in the coming years.

    I will rename my list so that it does not contain double quotes, and would greatly appreciate knowing when the double quote issue has been resolved so that I can go back to the original name.

    Thanks so much

  8. paulranker
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Jim,

    As long as you've updated the plugin to 2.0.1 (you should get a notice in your plugins panel), you can go back to using double quotes right away.

    Please let me know if I can assist you further.
    Paul

  9. jimflege
    Member
    Posted 10 months ago #

    Thanks very much Paul. It works now! Good job. The list is inserted on this page of our blog.

    http://travlearning.net/blog/great-small-towns/

    I see that the blog offers settings that affect width and height. If I fiddle, will I be able to make the list wider so as to reduce the amount of scrolling needed to see the whole thing? I did't get the desired effect immediately, but if the answer is "yes" I'll keep trying.

    Again: many thanks

  10. paulranker
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Jim,

    Making the widget wider will only bump up the font size of widget elements and give everything a little more space.

    If you'd like to reduce internal scrolling inside the widget you can either increase the Height option -the number being how many rows to display before scrolling kicks in. Or you can select the "all rows" checkbox and display all available rows.
    The second option is the one you want I think: your blog would be scrolled to see more items, not the widget.

    Thanks,
    Paul

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.