WordPress.org

Ready to get started?Download WordPress

Forums

Random sidebar appeared, can't get rid of it (18 posts)

  1. Harv696
    Member
    Posted 2 years ago #

    A sidebar appeared completely at random on the side of every one of my pages. I can't get rid of it, either. I have no sidebar widget, and no idea what could be causing this.

  2. Jeff Clark
    Member
    Posted 2 years ago #

    what is the link to your site?

  3. Harv696
    Member
    Posted 2 years ago #

    geoideas.net

  4. Jeff Clark
    Member
    Posted 2 years ago #

    Looks like its the main sidebar widget in your theme. Do you have any widgets activated in the main sidebar?

  5. Harv696
    Member
    Posted 2 years ago #

    No, and in the theme I'm using (Weaver 2010), and I don't see a widget labeled "main sidebar". There is one called "primary widget area" and like the others, it has nothing.

  6. Harv696
    Member
    Posted 2 years ago #

    Bump. The sidebar's still there. No widget for it, but it's there. As a side note, if I put a widget in the primary widget area, it will replace the sidebar, but when I remove it, the sidebar comes back.

  7. Harv696
    Member
    Posted 2 years ago #

    bump

  8. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    I believe it is related to the lines

    #primary, # secondary

    is style.css

    comment out that section

  9. Harv696
    Member
    Posted 2 years ago #

    Thanks for the reply! That didn't work though.

  10. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    I used a css mod tool and when i removed that css the widget disappeared...

    Remove these lines:

    #primary,
    #secondary {
    	float: right;
    	overflow: hidden;
    	width: 220px;
    }

    from http://www.geoideas.net/wp-content/themes/2010-weaver/style.css

  11. Harv696
    Member
    Posted 2 years ago #

    Thanks. That didn't work, but maybe becayse any changes I make to style.css aren't reflected in the link above? Why would that be?

  12. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Are you using any caching plugins? Also, clear your browser cache after making css or site mods.

  13. Harv696
    Member
    Posted 2 years ago #

    Wow, I feel a bit like the cat in the hat. Now the entire front page is a giant sidebar!

  14. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    I no longer see the widget!

    Try updating or using another modern browser.

  15. Harv696
    Member
    Posted 2 years ago #

    Scroll down on the main page. The "search" and "archives things are there, and the whole page is the color of the widget. It's as if the front page is somehow inside the widget itself! Do you see what I mean?

  16. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    No, I do not!

  17. Harv696
    Member
    Posted 2 years ago #

    Weird. Maybe a mac/chrome thing. I'll try to look at it on another computer. Thanks for your help!

  18. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    I would:

    A: Chuck that Mac out the Window
    B: Use IE9 on W7 or Firefox.

    Chrome was made to serve ads fast and cut down on server load at the we're not evil ppl.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.