WordPress.org

Ready to get started?Download WordPress

Forums

Random 500 Internal Server Error (godaddy) (29 posts)

  1. Tom Person
    Member
    Posted 4 years ago #

    Hi all,

    Let me introduce myself. I've been a .net developer for 9+ years, and I've had my share of IT support in the meantime (mostly managing SQL DB Servers, proxies, a firewell, etc), so I'm quite knowledgeable about computers and stuff.

    I'm experiencing random 500 internal server errors on my wordpress installation at godaddy, linux economy plan (shared server). I've been running this wordpress blog since March 2010, and i'm getting between 100-300 hits a day (doesn't sound like a lot). Something like 30 articles, and around 300 comments so far.

    The following is the list of active plugins:

    AdRotate
    Akismet
    All in One SEO Pack
    Contact Form 7
    Excerpt Editor
    Facebook Like Button Plugin
    Flickr Photo Album
    Google XML Sitemaps
    LinkWithin
    PHPlist
    Redirection
    Slickr Flickr
    Social Homes
    TubePress
    Twitter Tools
    Wordbook
    WordPress Database Backup
    WP-Polls

    It seems that as time passes I'm getting more and more random 500 internal server errors, and I'm worried this may be causing visitors to go away. I just ran an uptime test here http://host-tracker.com/check_res_ajx/5208052-0/share/ out of 81 requests, 31 failed!!! More than 30%! This is more or less in line with my personal subjective findings.

    I've researched a bit regarding this, it seems lots of people is having problems with wordpress in godaddy. Unfortunately they won't allow error log access to economy hosting plans, so i cannot do real troubleshooting, just trial and error. How would you suggest troubleshooting this problem? I'm seriously thinking about moving to a different hosting at this point.

    Any suggestions will be highly appreciated.

  2. Internal server errors are usually described in more detail in the server error log. If you have access to your server error log, generate the error again, note the date and time, then immediately check your server error log for anything useful. If you don't have access to your server error log, ask your hosting provider to look for you.

  3. Tom Person
    Member
    Posted 4 years ago #

    Update: I deactivated all plugins but Akismet. Guess what? I'm still getting 500 internal server error on between a high % of the requests according to Host Tracker (between 30% and 50%!). This is very, very bad.

    MacManX, as I stated, unfortunately i don't have access to my server error log (linux economy plan @ godaddy won't allow such a "privilege"). I'll try with a support ticket, but from what I've read so far regarding godaddy support, I wouldn't hold my breath.

  4. Tom Person
    Member
    Posted 4 years ago #

    Update: I was on the phone for around 20-30 minutes with godaddy. Guess what? They say that since I'm on economy plan, my hosting account doesn't even generate logs (something i feel hard to believe), and they "offered" an upgrade to the next level of hosting account so I could get access to the error logs and pinpoint the problem myself, and while at it they would move my hosting to one of the more "robust" web servers (?).

    I don't know what you think, but I feel this is not a very good customer policy. Seems like i have to pay just to get the privilege to access some error log, so I can *start* taking a look at the problem. I mean, upgrading to a higher plan won't even assure that the problem goes away, just that I'll be able to try to track down what's going on...

  5. I'm reasonably sure that the error log would point to the exact cause, but that doesn't always happen.

    Start by deactivating all plugins for a while (maybe leave Akismet active). If the 500 errors stop occurring, slowly begin to reactivate each plugin individually until you find the cause.

  6. Tom Person
    Member
    Posted 4 years ago #

    Hi MacManX, thanks for your reply. As I stated, I already tested deactivating all plugins, and the random problem still remains. I also contacted godaddy support via email in a new attempt to get a meaningful response out of them. All I got was a robotic response telling me that "error logs are only available for Deluxe and Unlimited hosting plans" and that "You may wish to consult with a community forum online or do a search on your favorite search engine as other users may have encountered a similar problem". So, no error logs, no luck. Note that when you go to the products page at godaddy, this error log limitation for economy hosting is not mentioned at all...

    I'm probably moving to bluehost, for a change. Godaddy support sucks.

  7. Samuel B
    moderator
    Posted 4 years ago #

    are you on a windows server?
    if so, switch to linux in hosting control panel

  8. Tom Person
    Member
    Posted 4 years ago #

    Samuel, no, as stated on my first post i'm on linux economy plan.

    :(

  9. mrmist
    Forum Janitor
    Posted 4 years ago #

    Are you seeing the 500 errors in Internet Explorer? If so, does visiting with another browser allow you to see more detail in the errors. (Probably not, but sometimes the IE pretty errors hide stuff.)

  10. mrmist
    Forum Janitor
    Posted 4 years ago #

    Another option whilst you are looking for other hosting might be to set up a test site on your computer. Export your database and import it to the test site, and load all the plugins/ theme. Then see if you get the errors locally.

  11. Tom Person
    Member
    Posted 4 years ago #

    Thanks for replying mrmist! I'm seeing the error on IE and FF and Chrome. I'll move the stuff from godaddy to my local LAMP installation and see what goes on...But something tells me everything's gonna be all right...While investigating this issue I see a ton of people having problems with wordpress+godaddy.

  12. Samuel B
    moderator
    Posted 4 years ago #

    I have been told that godaddy is going to spend time here in the forums helping their users. Wasn't given a timetable when this would start, but evidently they want to get on our preferred hosting list and will take measures to insure this.

    Maybe email their support and refer to this thread?

  13. I saw a GoDaddy rep on the forums yesterday, so I've added a "godaddy" tag to this topic in hopes that they stop by.

  14. Go Daddy
    Go Daddy Support
    Posted 4 years ago #

    Hi Tom Person,

    Sorry to hear this. You've probably noticed that 500 Internal Server Errors can be anything from long database queries to incorrect coding. Even large images or the server load could be the cause. Error logs would be helpful in pinpointing the issue and you can upgrade to deluxe at any time so you have access.

    Like you mention, you have quite a few plugins on your site. This may be slowing it down and causing the errors. I'd recommend trying out Supercache. Here's a great link for getting started and FAQ page from WordPress:

    http://www.wpbeginner.com/beginners-guide/how-to-install-and-setup-wp-super-cache-for-beginners/

    http://wordpress.org/extend/plugins/wp-super-cache/faq/

    In the meantime, we'll take a closer look at your issue. Thanks!

    Alicia
    GoDaddy.com

  15. Tom Person
    Member
    Posted 4 years ago #

    Ok, since i dont have time to move to a new hosting at the moment I upgraded to deluxe hosting plan. when checking my error logs I could see tons of errors like the following:

    [Fri Jul 23 08:21:18 2010] [error] [client 186.49.57.5] (104)Connection reset by peer: FastCGI: comm with server "/var/chroot/home/content/l/a/r/larutadelraid/html-x-httpd-php5" aborted: read failed

    [Fri Jul 23 08:21:18 2010] [error] [client 186.49.57.5] FastCGI: incomplete headers (0 bytes) received from server "/var/chroot/home/content/l/a/r/larutadelraid/html-x-httpd-php5"

    All right, since I've been digging on this for days, i remember reading about people having similar problems. So, I disabled Fast CGI php processor. It seems I've got rid of those errors, but now I'm getting tons of the following:

    [Fri Jul 23 11:01:26 2010] [error] [client 66.197.227.199] Premature end of script headers: /var/chroot/home/content/l/a/r/larutadelraid/html/index.php

    Does this say anything to you?

  16. That's not as descriptive as I'd like it to be, but that error does point to the possibility of a plugin conflict. If you deactivate everything but Akismet for about a day, do the errors stop?

  17. Go Daddy
    Go Daddy Support
    Posted 4 years ago #

    Thanks for the update. Your last error log gives a 'Premature end of script headers' error, then references your index file. This tells us that a script in your index file is responsible for your 500 Internal Server Errors. Unfortunately, there is not a simple fix for this one as the error is just saying that something didn't work. Like James (MacManX) mentioned, the error is likely related to a plugin. Try backing up your plugins folder, then deleting them completely and see if the same error occurs.

    Let us know how it goes!

    Alicia
    GoDaddy.com

  18. sephage
    Member
    Posted 4 years ago #

    I'm having the exact same issue with random Server 500 errors running a WP blog on GD shared Linux hosting.

    SAME experience with their phone tech support as well. They told me that it must be a WordPress issue and that I was on my own and should debug the WP scripts! Also tried to upsell me to hosting plan where I can access the logs, but I'm refusing - shouldn't have to pay more to a company if they aren't helping to solve a issue that **potentially could be due to their server config, etc.**

    If I deactivate all plugins I still get the error. Again, randomly and somewhat infrequently.

    I'm pretty close to asking GD to move me to another server, and then moving off of GD if we can't get this to work.

    I should note that my website takes under 5 seconds to load normally. However, once in a while things get very slow and the server throws the 500 errors. This is random - I cannot reproduce it on particular pages, or with particular steps, or with particular plugins activated.

  19. cewyattjr
    Member
    Posted 3 years ago #

    Anything resolved for folks on this? I've got the same issue. The minute I think it is resolved, I try again and have it back like a bad penny.

    The last change I made is to make sure and chmod everything that is WordPress/PHP-related 755 (executable). So far so good, but I'm not counting my chickens just yet. :-)

  20. cewyattjr
    Member
    Posted 3 years ago #

    Chickens counted. I think the chmod did it.

  21. cewyattjr
    Member
    Posted 3 years ago #

    Not. Didn't resolve it.

  22. Udi
    Member
    Posted 3 years ago #

    Well I'm getting the same issues, "premature end of script headers" error.
    I have deluxe hosting at godaddy and I also have quiet a few plugins installed.
    So in order to test it with no plugins I've installed another wordpress system under different subdomain and different MYSql and no plugins at all, just clean install of the wordpress an problem is happening also on the clean install.
    The full blog is blog.udiburg.com and the test one is staging1.udiburg.com.

    Godaddy team,
    Would you consider better support on this? Cause it looks like it has nothing to do with the WordPress but with the combination of WordPress on godaddy.
    This doesn't happen on another hosting or on a dedicated Linux server I've installed in my lab.

  23. cewyattjr
    Member
    Posted 3 years ago #

    Hey 007me... no resolution for me either. My client plans to upgrade from economy hosting to deluxe just so I can see what the error log looks like. Until then, because it is a predictably sporadic problem, they haven't seen it and so therefore it doesn't exist.

    The symptom I see looks like some kind of database/web server latency. If the web server hasn't spoken with the DB server in some time, it throws the error. Refresh and everything is fine!

    Thinking about moving to a different hosting provider -- on my own development site, which is also shared hosting, it worked with no problems.

    -Chuck

  24. Udi
    Member
    Posted 3 years ago #

    Well, it looks like godaddy doesn't care if their clients will move to another hosting cause they have so many customers.
    I'm running a ticket for 2 days now with them with no help.
    they keep telling me that it's a WordPress issue.

  25. cewyattjr
    Member
    Posted 3 years ago #

    Any further word, 007me? What's interesting is that your test blog produced the same results. That pretty much rules out the problem being with WordPress, I would think.

    BTW, I went to your staging blog and the live one and didn't see any errors at all, but as we know this is a random issue. I had found with my testing that the error seemed to occur more when I turned OFF database caching. I'm using a plugin called "hyper-cache," and with it turned off errors occurred with greater frequency, which leads me to believe the issue is some kind of network latency between the web server and database server.

  26. Udi
    Member
    Posted 3 years ago #

    Cewyattjr, as you know it's random, and if you will try each blog few times you'll see the error.
    I'm using now super-cache plug-in and now I have less errors, so I must agree with you that the problem is on Godaddy side.
    Their support finally answered me and said that because I installed the WP manually I have all the errors and that I should use their Auto WP install.
    But, they are providing the auto install with PHP4.2 instead of PHP5 and many plug-ins need the PHP5 in order to work.
    Big mess with Godaddy.

  27. cewyattjr
    Member
    Posted 3 years ago #

    I was wondering how the "auto install" would work, and disappointing that it is only PHP 4.2. I imagine I have the issue that certain plugins need PHP5.

    Would be interesting to test... Do you happen to know where it is in the GD configuration that selects PHP 4 versus PHP5? I looked in .htaccess for my current site with the issues and another one with their auto install and don't see any PHP5 cgi version selected with either.

    Thanks so much!

  28. Udi
    Member
    Posted 3 years ago #

    Well, they just sent me instructions how to change the PHP:

    Be aware that the PHP version on the account is related to the option which you selected when creating the plan. Our system does not automatically select a version of PHP to use when you install an application through our Hosting Connection interface. If you wish to change the PHP version, you can do so by following these directions:

    1. Log in to your Account Manager.
    2. From the Products section, click Web Hosting.
    3. Next to the hosting account you want to use, click Launch.
    4. In the Content section of the Hosting Control Center, click the Add-On Languages icon.
    5. Select the PHP version you want to use.
    6. Click Continue.
    7. Click Update.

  29. shrunyan
    Member
    Posted 3 years ago #

    I'm seeing a 500 internal server error as well but it only appears in the admin area.

    It seems to be a clash between All-In-One-SEO-Pack and Tubepress.

    If I deactivate all plugins and begin reactivating them one by one, once Tubepress is activated everything works until all-in-one-seo is activated.

    I'm currently still looking for a solution.

Topic Closed

This topic has been closed to new replies.

About this Topic