WordPress.org

Ready to get started?Download WordPress

Forums

Rackspace Cloud Sites - An Unexpected HTTP Error occurred during the API request (9 posts)

  1. PromptInternet
    Member
    Posted 3 years ago #

    First of all, I'm using Rackspace cloud sites.

    The site is unable to reach WordPress's plugin / update API.

    When search for a plugin I get: An Unexpected HTTP Error occurred during the API request.

    On the Dashboard I get: RSS Error: WP HTTP Error: connect() timed out!

    All WordPress back-ends are super slow on Cloud Sites now because it's waiting on the API.

    I can't install or update plugins, see the WordPress blog feed on the dashboard, or update WordPress.

    I already contacted them about this issue and they told me the WordPress API is blocking my sites somehow. They could be totally wrong I don't know - but they weren't much help.

    Help would be VERY MUCH appreciated. O.o Thanks.

    P.S. I'm not having the issue on a dedicated server I own, just on the cloud sites (though it used to work fine), but I have not tested it on any other hosts.

  2. bmuldowney
    Member
    Posted 3 years ago #

    I am having the same issue

  3. PromptInternet
    Member
    Posted 3 years ago #

    You're using Rackspace Cloud Sites too?

  4. bmuldowney
    Member
    Posted 3 years ago #

    Yes

  5. bmuldowney
    Member
    Posted 3 years ago #

    Just heard back from Rackspace. Here's what they had to say:

    Currently we are experiencing an issue with the SAT datacenter making calls out via the WordPress API - this is being corrected however there is not yet a firm ETA.

    Please proceed by retrieving the wordpress core/plugin updates from their site directly, and uploading them via ftp. This is the current workaround.

  6. PromptInternet
    Member
    Posted 3 years ago #

    Wow... This is literally what they told me:

    Kelly C: This is currently a wordpress issue. They will need to be contacted for more information. WordPress is the one blocking the api. They will be the ones to give you an ETA.
    Me: That's not right because if I copy the site to a different server it works fine.
    Kelly C: WordPress is blocking the api. This isn't something we can fix on our end.
    Me: How are they blocking the API if it works fine on another server? Are you saying they're only blocking rackspace?
    Kelly C: Yes.

    And updating via FTP is not a big deal, but that doesn't solve our issue of the entire back-end chugging along while it's trying to connect to the WordPress API.

    Anyone know how to temporarily disable connecting to the API for the WordPress blog, popular plugins, etc?

  7. Ronnie
    Member
    Posted 3 years ago #

    Same issues here as well. Even my Analytics360 plugin has issues accessing Google Analytics and MailChimp. It seems to be more of an issue with the HTTP Module making any outbound connections. Not just to WordPress.

  8. PromptInternet
    Member
    Posted 3 years ago #

    Well... it looks like they fixed it.

    To answer my own question - if you wanted to block outgoing requests you could add this to wp-config:

    define('WP_HTTP_BLOCK_EXTERNAL', true);

  9. Hubert Nguyen
    Member
    Posted 3 years ago #

    Are you having issues when performing core updates as well? With Cloudsites, it's not uncommon that the core updates would not execute completely due to the 30sec time-out of the load-balancer. It works on small sites, but can hang for big sites (lots of posts).

Topic Closed

This topic has been closed to new replies.

About this Topic