WordPress.org

Ready to get started?Download WordPress

Forums

Pinboard
[resolved] Quotes Look Funky (14 posts)

  1. phyllisrae
    Member
    Posted 1 year ago #

    I just uploaded my blog to wordpress from another site and I noticed that my quotes look all weird. I thought maybe formatting had screwed up in the transfer, but I made a new post without any prior formatting and got the same issue.

    It's like all these special characters are inserted into my "quote" posts, so that the quote appears all screwed up on the main blog page.

    My site is phyllisrae.com, and if you go to the blog you can see what it looks like.

    I don't have any clue how to fix this as I don't know what's wrong...I tried removing all formatting beyond the fact that it's a quote. Simply having it just as a "quote" format post makes it appear blank. It seems like the code of "blockquote" is what is causing this, but I don't know an alternative way to make a quote without using this code.

  2. phyllisrae
    Member
    Posted 1 year ago #

    Oh, I also wanted to add that this is only happening on the preview, not on the actual permalink once you click on the post.

  3. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    You have an under-construction page up so hard to check on what you are referring to... Perhaps you just need to change the styling for blockquote ? You can do that by adding CSS to custom CSS or using a Child Theme if you are likely to modify theme files.

    http://codex.wordpress.org/Child_Themes

    (Any changes to theme files will be lost when the theme is updated so you want to avoid modifying them directly...)

    EDIT - if it's only preview, that may be a different issue, but does that really matter?

  4. phyllisrae
    Member
    Posted 1 year ago #

    Yeah, I have a construction page up for the main site...I have a menu bar up that leads to the blog page. That's where the issue is occurring, not on the main page.

  5. phyllisrae
    Member
    Posted 1 year ago #

    I'm not really sure what custom CSS to add to fix this issue. It only seems to be doing this if I use a block quote (aka, press the quote button and write up a quote), which is also an HTML block quote in the code? If I take this away, and make it a quote-formatted page, but don't have the actual quote coded as a "blockquote", nothing shows up. It'll be blank on the main "blog" page and then when I click on that post, it'll show up as the permalink.

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    So is there a problem with the actual page display of it? I see different characters, but is that what you entered? Do you want to change the CSS for the blockquote on the actual pages? What does preview show or not show that's different?

  7. phyllisrae
    Member
    Posted 1 year ago #

    Yeah..it's displaying extra characters I didn't enter. I just typed a standard quote, with regular characters, like, example: "Hello, I'm a person. - Me" and when it shows up on the list of blog posts, a bunch of extra superfluous characters are added that don't belong there.

    If you click on that post, the weird characters aren't there anymore. It's just in the preview of the quotes, and it's only when I have a quote post. It doesn't show up on regular posts as far as I know.

    My most recent quote shows up like this:

    "Test­ing my quotes
    –Me"

    Even though I didn't put any of those special characters there. It's supposed to just say, "Testing my quotes - Me" and I posted it there that way because one of my earlier quotes from Tumblr was doing the same thing. I thought maybe it was an error on Tumblr's part from the transfer, but it isn't.

  8. phyllisrae
    Member
    Posted 1 year ago #

  9. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Weird - yeah, that's what I was seeing too - I installed the theme on a test site and it did not repeat that oddness. But I just looked at your code again and wonder if it's because you also used italic (<em>) tags - try it without doing that...

  10. phyllisrae
    Member
    Posted 1 year ago #

    I added that afterward I think, but I'll try it again. Maybe I have to reinstall the theme? Hmm....

    ...Nope. That was only applied to one quote, and all of the quotes do it, including the one that I uploaded from Tumblr. Maybe it's just a glitch, then..I can't think of any other reason why it would happen.

    If I uninstall and reinstall the theme, though..I need to back up what I currently have first, right? Do you think this would help perhaps get rid of the issue, whatever it is?

  11. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I really don't know. Here's maybe something - though I don't know if this is a result of or a cause of those:

    http://validator.w3.org/check?uri=http%3A%2F%2Fphyllisrae.com%2Fblog%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

    That error has to do with encoding... Are you copying text from someplace or just entering it in the dashboard. And is this imported from another site?

  12. phyllisrae
    Member
    Posted 1 year ago #

    The first quote, from Brenda whats-her-name, was from Tumblr. It doesn't show up immediately on the front page and you have to let some of the older posts load.

    The other ones (that are at the top, with Picasso and etc) I added directly from dashboard (but as plain text) as a result of noticing the error. I made sure to paste them as plain text to make sure that nothing weird would happen, and it still kept happening.

    So... it would seem to me that the errors are being caused by the quotes, not resulting from them, but I don't know. :(

  13. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I would first try typing a new entry/quote directly into the dashboard - don't paste anything. Also be sure you are not changing between the visual and text editors - that does cause problems.

    Then I would try deactivating all your plugins and switching to the default theme to see if you have the problem still (or any other oddities with text or anything else).

    You could certainly try reinstalling the theme, but I kinda doubt it's the theme because the problem would have likely showed up for other people... But you never know about strange things, so it's worth a try if the above steps don't offer any more info/fixes.

  14. phyllisrae
    Member
    Posted 1 year ago #

    Aha! I found it. I had a plugin called wp-Typography, which I had activated but not used yet. As soon as I deactivated it, the issue went away. There must be a conflict between the typography settings in the template and the plugin--makes sense.

    Usually I keep plugins deactivated until I'm ready to use them-I dunno why this one was still on, I wasn't even remotely using it.

    Good work!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic