WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials by Aihrus
[resolved] quotation marks above and below each testimonial printed to the page (23 posts)

  1. ramedia
    Member
    Posted 1 year ago #

    I think this is because you are surrounding the testimonial with paragraph tags (or wordpress is adding them). Is there a workaround with css to get the quotes to inline with the testimonial.

    This is what mine look like on the page:

    "
    quote is here.
    "
    newest version of wp 3.5, newest version of plugin 2.5.5

    http://wordpress.org/extend/plugins/testimonials-widget/

  2. ramedia
    Member
    Posted 1 year ago #

    I figured it out. You have to add this to the widget's css file:

    .testimonialswidget_testimonial q p {
    display: inline;

    }

    you've corrected the display for the widget, but not for the page:
    .widget .testimonialswidget_testimonial q p {
    display: inline;

    }

  3. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    I wonder if q should be inline. Otherwise, with p being inline, the paragraph breaks are lost.

    Your thoughts?

  4. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    What about…

    .testimonialswidget_testimonial q p:first-child {
    margin-top: 0;
    padding-top; 0;
    }
    
    .testimonialswidget_testimonial q p:last-child {
    margin-bottom: 0;
    padding-bottom; 0;
    }

    This way the p tags aren't collapsed completely.

  5. mjw01
    Member
    Posted 1 year ago #

    I have the same problem with new install of the plugin. I added the code suggested and found no change. Currently with or without change:

    "
    Mr. Weaver was a great instructor who added significant material to the baseline slides.
    "
    Gary B.

    "
    The teacher is really knowledgeable.

    "
    Mei L.

  6. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    I'm still experimenting with this. Not an easy one I think.

  7. mjw01
    Member
    Posted 1 year ago #

    Thanks for the quick response. My intent is to create a simple page that has list of all testimonials. Either,

    (a) similar to widget display in sidebar, or

    (b) as a bulleted list (e.g., [li][testimonial]—[name][/li])

    Matthew

  8. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    MIght be easier to just say q{ quotes:none; } and then style q::before and q::after with some graphics that have a load of spacing with them.

  9. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Resolved with version 2.7.3 of of Testimonials Widget.

  10. puruz
    Member
    Posted 1 year ago #

    Hi I am having this issue. How do I resolve?

  11. kadeskakes
    Member
    Posted 1 year ago #

    Hi - I didn't start having this issue until I downloaded version 2.7.3 today. Any ideas?

  12. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    The underlying CSS and HTML have changed.

    Have you cleared browser cache?

    Have you cleared your CDN of CSS files?

    If still broken, please provide URLs of where the problem is happening for me to debug further.

  13. kadeskakes
    Member
    Posted 1 year ago #

    I cleared my browser cache and the cache in my WP Super Cache plugin, and that didn't help. I'm a bit new to all this, though, so I'm not really sure how to clear my clear my CDN of CSS files...

  14. edwardv2
    Member
    Posted 1 year ago #

    I too am having this same problem. It started with v 2.7.3 (I think) and I've upgraded to v 1.7.4 and still have this problem. The weird part is half of the testimonials are fine and the other half have this problem. I thought I found it when I discovered some of the testimonials were formatted justified left and right but after changing these it still didn't work.

    The website is http://www.qdinformation.com

  15. puruz
    Member
    Posted 1 year ago #

    Hi you can see it http://www.puruz.com/partners

    thanks!

  16. edwardv2
    Member
    Posted 1 year ago #

    I solved my issue. WordPress evidently had added some formatting markup to the "posts". Since I almost always edit in visual mode I didn't see it. Switching to text mode and removing all markup such as <p> and even <div> in one case.

    It's strange because before the recent updates it was working fine. Evidently adding the quotes caused the problem.

    Solution: Switch to text mode and remove all markup!

  17. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    You're pretty close to the answer regarding the visual editor adding extra markup causing trouble.

    More specifically, as in Puruz's case, it's that the testimonials are wrapped in h4 tags which are display: block. As such, the open quote span is forced to a newline.

  18. puruz
    Member
    Posted 1 year ago #

    Getting rid of the tags worked...thanks!

  19. jamesosix
    Member
    Posted 1 year ago #

    Hi, i think I am having a problem similar to this.

    The quotes are linked and I want to remove the quotes. I have tried question 13 in the faq, but it never worked.

    HTML

    <h2>Testimonials</h2>
    [testimonialswidget_list limit=1 random=true]

    CSS (as instructed in Q13

    .testimonialswidget_testimonial .testimonialswidget_open_quote:before,
    .testimonialswidget_testimonial .testimonialswidget_close_quote:after {
        content: none;
    }

    The url where the quotes can be seen is http://expertwebsitereview.co.uk

    Thanks in advance!

  20. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    The testimonial seems fine to me. It's without quotes on OSX Chrome and Safari.

    I figure your browser cache needs clearing.

  21. jamesosix
    Member
    Posted 1 year ago #

    Hi, sorry forgot to update, but I have fixed it today.

    It was the pagination. It wasn't working properly (it linked to the url of the next testimonial I think, but when clicked, returned a 404).

    I didnt want the pagination anyway, so I just added display: none; in the css for the pagination and it now looks fine.

    Thanks anyway and great plugin! :)

  22. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    You can set paging=false in your shortcode to disable it.

  23. jamesosix
    Member
    Posted 1 year ago #

    silly me. Never even thought about that! I'll sort it out now. Thanks for timely support! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic