WordPress.org

Ready to get started?Download WordPress

Forums

Widget Wrangler
[resolved] QuickEdit deletes code in Advanced Parsing (3 posts)

  1. JochenT
    Member
    Posted 5 months ago #

    Hi Jonathan,

    I've encountered some problems during the last days. I put them in separate posts.
    This one is an old error reappearing. When using 'QuickEdit' mode the values are sent as GET parameters now. In your plugin you do check only for POST parameters. Also the current name 'quickeditfix' is misleading and results in wrong logic. I've found that QuickEdit sends a param '_inline_edit'. I think this is easier and more clear. You may replace in file ww-widget-class.php line 161:
    if (isset($_POST['quickeditfix']) && $_POST['quickeditfix'] != "true") { return; }
    with
    if (isset($_REQUEST['_inline_edit'])) { return; }

    Line 256 can be deleted.

    https://wordpress.org/plugins/widget-wrangler/

  2. Jonathan Daggerhart
    Member
    Plugin Author

    Posted 5 months ago #

    Thanks for the report. This is re-fixed in the newest release (1.5.3). Let me know if you continue to have issues.

    Commit https://plugins.trac.wordpress.org/changeset/873764

  3. JochenT
    Member
    Posted 5 months ago #

    I've tested this and it does not drop the content of the 'Advanced Parsing' section any more. Thanks for the update.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.