WordPress.org

Ready to get started?Download WordPress

Forums

SSL Insecure Content Fixer
[resolved] Quick Flag plugin still delivered over http (8 posts)

  1. magnus911
    Member
    Posted 6 months ago #

    First off, thanks for an awesome plugin.

    I am using a plugin called quick count and quick flag to show how many users are logged in and where they're from.

    However, the quick flag plugin still won't deliver over https resulting in an error.

    https://www.traderxaspen.com

    Thanks in advance.

    http://wordpress.org/plugins/ssl-insecure-content-fixer/

  2. webaware
    Member
    Plugin Author

    Posted 6 months ago #

    G'day Magnus,

    I looked at a few pages on your website, and saw no errors. What browser and what page?

    cheers,
    Ross

  3. magnus911
    Member
    Posted 6 months ago #

    Sorry, I deactivated the offending plugin, should be back up now!

  4. webaware
    Member
    Plugin Author

    Posted 6 months ago #

    You'll need to edit the plugin to fix this one. Open up the file quick-flag.php in the Quick Flags plugin, and change line 62 from this:

    $this->url = WP_PLUGIN_URL . '/' . self::slug;

    to this:

    $this->url = rtrim(plugin_dir_url(__FILE__), '/');

    If that works, open up a support ticket on the Quick Flag support forum and tell them what you had to do.

    cheers,
    Ross

  5. magnus911
    Member
    Posted 6 months ago #

    That appears to work perfectly...thanks so much.

    I really appreciate your immediate help and the great plugin.

    Let me know how to return the favor.

  6. webaware
    Member
    Plugin Author

    Posted 6 months ago #

    That review was great, thanks :)

    cheers,
    Ross

  7. webaware
    Member
    Plugin Author

    Posted 6 months ago #

    @magnus911: don't forget to open up a support ticket on the Quick Flag support forum and tell them what you had to do!

  8. magnus911
    Member
    Posted 6 months ago #

    i was doing that...and then I added a second comment with the code you supplied and it said that wordpress had closed the thread! It was bizarre. Will try again.

Reply

You must log in to post.

About this Plugin

About this Topic