WordPress.org

Ready to get started?Download WordPress

Forums

WP Social SEO Booster - Knowledge Graph Social Signals SEO
[resolved] quick fixes to code (5 posts)

  1. lunaraurora
    Member
    Posted 1 year ago #

    Just quick fixes to your code, to comply with w3c validator (in case you are interested):

    edit
    wp-content/plugins/wp-social-seo-booster/includes/widgets/wps-seo-booster-ratings-widget.php

    line 167:
    tag not closed:
    replace
    <tr>
    with
    </tr>

    line 255:
    replace
    <td width="90px" class="wps-seo-booster-rating-td" align="center">
    with
    <td width="90" class="wps-seo-booster-rating-td" align="center">
    to avoid an error with w3c validator

    line 257:
    replace
    <span class="wps-seo-booster-rating wps-seo-booster-stars_' . $stars . '"></span>
    with
    <span class="wps-seo-booster-rating wps-seo-booster-stars_' . $stars . '">&+nbsp;</span> (remove the '+' after '&' and before 'nbsp;')
    this will fix an empty tag and make valid the code in w3c

    There are also many tags not closed in this file:
    wp-content/plugins/wp-social-seo-booster/includes/wps-seo-booster-ogp.php

    EX:
    <meta property="og:title" content="' . esc_attr( $home_title ) . '">
    and many others, without the proper trailing slash ( /> ) that close the tag.
    I hope to have contributed a little

    http://wordpress.org/extend/plugins/wp-social-seo-booster/

  2. Daniel
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Thanks a lot for that. I'll fix the widget, but the closing
    tags are not necessary for meta tags in HTML5
    http://stackoverflow.com/questions/3558119/are-self-closing-tags-valid-in-html5

  3. Daniel
    Member
    Plugin Author

    Posted 1 year ago #

    I just released an update with a fix for the widget.

    Daniel

  4. lunaraurora
    Member
    Posted 1 year ago #

    Great Daniel, for the next update would be useful to start the id with a letter instead of a number
    EX:
    wrong:
    <span style="display:none;" id="2268"></span>
    correct:
    <span style="display:none;" id="n2268"></span>
    ..i know, could be stupid but w3c see it as an error.

    Regards!
    Jeff

  5. Daniel
    Member
    Plugin Author

    Posted 1 year ago #

    Jeff,

    The ID is the Post ID which we need for the rating so that we know to which post that rating has to be added. So with that, I can't add a letter to the ID.

    Daniel

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.