WordPress.org

Ready to get started?Download WordPress

Forums

Email Users
[resolved] Quick fix to save ' exclude sender from email recipient list' setting (4 posts)

  1. ericadecker
    Member
    Posted 1 year ago #

    On line 123 of email_users_options_form.php, you should see:
    <input type="checkbox" name="mailusers_from__sender_exclude" id="mailusers_from__sender_exclude" value="true" <?php if (mailusers_get_from_sender_exclude()=='true') echo 'checked="checked"';?> ></input>

    Remove the extra underscores before 'sender', and you should be able to save that setting:
    <input type="checkbox" name="mailusers_from_sender_exclude" id="mailusers_from_sender_exclude" value="true" <?php if (mailusers_get_from_sender_exclude()=='true') echo 'checked="checked"';?> ></input>

    http://wordpress.org/extend/plugins/email-users/

  2. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    I have posted a beta build of Email Users 4.4.3 which addresses this problem. If you have a few minutes please verify it works correctly for you.

  3. bksilverthorne
    Member
    Posted 3 months ago #

    I tired this. I even tried it on the new build. The code in my version does not contain the double underscores and the setting still cannot be saved.

  4. Mike Walsh
    Member
    Plugin Author

    Posted 3 months ago #

    What version of Email Users are you using?

    In 4.6.6 I am able to save the checkbox state for the Sender Exclude option either as checked or unchecked.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic