WordPress.org

Ready to get started?Download WordPress

Forums

Editorial Calendar
Quick edit does not work anymore (5 posts)

  1. Nauhaie
    Member
    Posted 9 months ago #

    Hi,

    Is it only me, or the quick edit pan doesn't work anymore? When I try to use it to update a post, the post just stays untouched, and my JS console says

    'null' is not an object (evaluating 'a.error').

    The 'new post' pan however does work.

    I am using WordPress 3.6.1, but honestly I hadn't used the quick fix pan for a while, so I can't way when the problem started.

    Thanks a lot,
    Nauhaie

    http://wordpress.org/plugins/editorial-calendar/

  2. Nauhaie
    Member
    Posted 9 months ago #

    Ok, so after a lot of tests, here is what I came up with... It turns out that the problem is caused by the date format.

    In French, the default WordPress date format is something like 14 h 52 min (which means 2:52 PM). Thus, in the date field of the quick edit pan, what is shown is 14 h 52 min (instead of 2:52 PM), which then fails to be parsed by the edcal_savepost ajax action... Hence the post is not updated.

  3. Nauhaie
    Member
    Posted 9 months ago #

    Oops, in fact the parsing is done in JS, and not in the edcal_savepost ajax action. Anyway, if anybody runs into the same problem, here is a quick way of fixing it: in edcal.php -> edcal_postJSON(...), replace the line

    "time" : "<?php echo trim(get_the_time()) ?>",

    with

    "time" : "<?php echo trim(get_the_time("H:i")) ?>",

    and everything will work fine, even though the times won't be displayed in a very consistent way.

    Zack, could you do something about it so that we don't get to do that manually after each update?

  4. Zack Grossbart
    Member
    Plugin Author

    Posted 8 months ago #

    Thanks for putting so much effort into tracking this down. I've tried the calendar in French without a problem. Is there some special way that I need to set this up so I can reproduce this issue and then I can fix it.

    Thanks,
    Zack

  5. Nauhaie
    Member
    Posted 8 months ago #

    Thanks for looking into it. The problem only occurs if the time format ("format d'heure") in general settings is "x h yy min", which is the default value in French...

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.