WordPress.org

Ready to get started?Download WordPress

Forums

Quick Edit broken, Visibility Settings broken, please fix ASAP (22 posts)

  1. annias
    Member
    Posted 3 years ago #

    WordPress,

    Thank you for a great product. That said, since the last update I am having a serious functionality problem. I have seen it mentioned on other posts briefly as well but no resolution has been made.

    When in page or post overview, selecting "quick edit" makes the post or page disappear from the overview. You can not edit/use any quick edit functions.

    Trying to work around this problem, I click on a specific article or page so that I can modify it's privacy settings (ie public, private, add a password etc) When I select for instance "Password Protected", no dialog box comes up for the password to be entered, and upon hitting "Ok" the screen resets at a different position vertically to have the visibility section at the top right, but no actual action occurs and you can still not add a password or edit one currently on a page.

    I have tried this in 5 browsers on several pcs with caches completely cleared to no avail. This has to be addressed and hopefully very soon.

    Thank you for your time,

    Charles

  2. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    When in page or post overview, selecting "quick edit" makes the post or page disappear from the overview.

    That is normal behavior.

    You can not edit/use any quick edit functions.

    All the functions should be there. Including "password" and a box next to it for entering a password.

    If you do not have these functions you either have a incomplete install or a misbehaving plugin.

  3. annias
    Member
    Posted 3 years ago #

    How is that normal behavior? When selecting quick edit the post/page usually opens into an expanded dialog box which allows for the actual "quick editing" to be performed. What is normal about a post/page disappearing from the list once selected?

    Also nothing has been changed, I am updated to the current version of WP, all plugins disabled, and have not made any changes other than the upgrade to 3.2.1

    I appreciate your feedback but what "should" happen and what is happening are two different things. I need to find some kind of resolution to this issue.

  4. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

  5. dowster
    Member
    Posted 2 years ago #

    This isn't very helpful to be honest. I've just discovered the same problem too.

    Clicking "quick edit" makes the post disappear... I presume the edit version should appear.

    I'm guessing this is down to some jquery script that being applied by a theme?

  6. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Clicking "quick edit" makes the post disappear

    I don't understand "disappear"?

    You open "all posts," you mouse over the post you want, Edit|Quick Edit, etc. appear, click on Quick Edit and a box opens with choices. Is that what you are talking about? The post does not open unless you choose "edit." This is what is supposed to happen.

    Quick Edit is just an in-line edit that allows you to change the following items--Title, Slug, Date, Author, Password or Private post box, Categories, Tags, Allow Comments, Allow Pings, Status, and Make this a post-sticky.

  7. dowster
    Member
    Posted 2 years ago #

    In "All Posts" when you click upon "Quick Edit" the post in question disappears.

  8. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    You open "all posts," you mouse over the post you want, Edit|Quick Edit, etc. appear, click on Quick Edit and a box opens with choices.

    That is exactly what is supposed to happen. It is really in a quick edit for things about the post not the content of the post.

    Quick Edit allows you to change the following items, Title, Slug, Date, Author, Password or Private post box, Categories, Tags, Allow Comments, Allow Pings, Status, and Make this a post-sticky.

  9. dowster
    Member
    Posted 2 years ago #

    But the edit form field do not appear and the post vanishes... it's probably a jquery issue

  10. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Have you tried:
    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Don't forget the ones in mu-plugins if you have that folder. If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.
    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

  11. dowster
    Member
    Posted 2 years ago #

    Thanks for your help

  12. toao
    Member
    Posted 2 years ago #

    Has anyone found a solution to this problem? This is extremely annoying.

  13. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

    toao - did you try what kmessinger suggested a couple of posts up - to rule out a plugin or theme issue?

  14. paulo72
    Member
    Posted 2 years ago #

    After a WordPress update I got the following problems:

    • In /wp-admin/edit.php?post_type=page — clicking 'quick edit' link made the page disapear from the list
    • Clicking the permalink 'edit' button didn't work (you couldn't edit the permalink)
    • It was impossible to set the pages visability settings, set to draft etc.

    I tried:
    - All plugins deactivated
    - Delete and replace wp_admin and wp_includes folders
    - added define('CONCATENATE_SCRIPTS', false ); to the wp_config

    It turned out to be a javascript colour picker in a custom admin panel in the theme did not like the upgrade. Commented out the JS and Bob‘s yer uncle, it worked.

  15. RedBjarne
    Member
    Posted 2 years ago #

    Same problems here, after the 3.2.1 update. Quick-Edit makes the post dissapear from the list.
    Extremely annoying problem..

  16. PianoRock
    Member
    Posted 2 years ago #

    I am also having the same issue mentioned above with 3.2.1: Clicking Quick Edit on posts marked as Private hides the page that I'm trying to Quick Edit from the list of all pages.

    I have tried deactivating all plugins.

  17. dickelkin1
    Member
    Posted 2 years ago #

    This is still happening. I need QuickEdit since it is the only way I can find to not have comments on a page. Full edit doesn't offer this option - another bug, in my view.
    The first four pages I created allow quick edits, from then on, it doesn't.

  18. mdf4
    Member
    Posted 2 years ago #

    Has anyone been able to fix this? I'm having a similar problem, can't click on quick edit (it does nothing) and trying to change the visibility setting results in making the page scroll further down. I also can't seem to create new pages.

    Everything was working great a few days ago and I haven't changed anything - but since noticing the problem I've disabled all plugins, switched to the 2011 theme and tried re-installing WordPress, but still have the same results. Any ideas?

  19. Suber
    Member
    Posted 2 years ago #

    I fixed this problem by deactivating my "No Follow" plugin

  20. markevnic72
    Member
    Posted 2 years ago #

    I have the same problems. Visibility settings don't work in the post/page editor, and click-through to a post from the dashboard initially shows no content in the editor for the page, although highlighting indicates all the html/content is there but white. Quick edit/ edit buttons don't work.
    I tried turning off the plugins and nothing's improved.. I do see that the wp-admin FOLDER in the FTP client has a modify date of two days ago which is odd. In the folder, I don't see any actual files with a similar modify date. Could the new date on the wp-admin folder be part of the problem? I don't know how it was modified... Can anyone help please?

  21. markevnic72
    Member
    Posted 2 years ago #

    all, problem fixed. So the file "admin-footer.php" had vanished from the directory in wp-admin. Who knows why, perhaps an accidental 'drag' as I was uploading and downloading ... I replaced that one file and everything works normally again. Lesson here, don't drag files in and out of the FTP window to up/download them, use the menu commands!!!

  22. Lucas
    Member
    Posted 2 years ago #

    Hey.

    I've been having the same problem with quick edit since I upgraded to a newer version on one of my sites. I'm aware of how it's supposed to work: it was working fine before I upgraded. Site A was using an adapted version of the theme lightword, and running many plugins.

    Site B is another site of mine, running the same theme and same plugins. When upgraded to the new version of wordpress, it worked completely as expected.

    I fixed site A by reactivating all plugins and themes. That fixed everything.

Topic Closed

This topic has been closed to new replies.

About this Topic