WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] qTranslate broken with BPS (11 posts)

  1. simonysandra
    Member
    Posted 1 year ago #

    Hi,

    I have problems with qTranslate not working when trying to post or write a page. Also the search function is putting an extra language code to the url which gives 404 when making a search query.

    I deactivated BPS without uninstalling it because I really apreciate the plugins' results in security.

    Any ideas what I can do?

    Thank you

    http://wordpress.org/extend/plugins/bulletproof-security/

  2. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Deactivating BPS means you no longer have the built-in troubleshooting tools that come with BPS. See the troubleshooting steps below.

    I have problems with qTranslate not working when trying to post or
    write a page. Also the search function is putting an extra language
    code to the url which gives 404 when making a search query.

    I need specific details about the issue/problem in order to troubleshoot the issue/problem. Is posting or writing a page with qtranslate installed the same as normal WordPress posting and writing?
    What search function where? Is this a feature in qtranslate? What does this mean - "putting an extra language
    code to the url which gives 404 when making a search query"? Please explain in detail. Once I understand what you are talking about then I will test qtranslate to see what the issue/problem is. Thanks.

    Source: http://forum.ait-pro.com/forums/topic/read-me-first-free/

    BPS Troubleshooting Steps

    If you think that BulletProof Security is causing a plugin conflict or any other issue on your website that is causing something not to work, then please use these steps below to take BulletProof Security out of the equation completely for testing. There is no need to deactivate BulletProof Security because it has a built-in Default Mode that allows you to put WordPress in a default state without deactivating BulletProof Security. If you find that BulletProof Security does have a conflict with another plugin then please check the BulletProof Security Plugin Compatibility Issues – Testing and Fixes Page to see if a fix (bypass/skip rule) is already listed. If your plugin is not listed and you have confirmed that BulletProof Security is definitely causing a conflict then please post a comment in this Forum.

    1. Make a backup of your .htaccess files using BulletProof Security built-in Backup.
    2. Activate Default Mode on the Security Modes page.
    3. Use the Delete wp-admin .htaccess feature on the Security Modes page.
    4. Test your plugin or theme.
    5. Restore your .htaccess files using BulletProof Security built-in Restore.

    To completely uninstall BulletProof Security you would do steps 2 and 3 above and then just delete the BulletProof Security plugin on the WP Plugins page.

  3. AITpro
    Member
    Plugin Author

    Posted 1 year ago #


  4. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    What version of WordPress do you have?
    When I try to test qtranslate I see this message below.

    The qTranslate Editor has disabled itself because it hasn't been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version.

  5. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    I upgraded qtranslate to version: 2.5.34 and have tested qtranslate on WordPress 3.5.1 with BPS.

    I tested creating a post - no errors, conflicts or problems.
    I have no idea what you are talking about regarding this - "Also the search function is putting an extra language code to the url which gives 404 when making a search query." But this does not sound like it has anything to do with BPS and is another problem. Thanks.

  6. simonysandra
    Member
    Posted 1 year ago #

    Hi,

    Thank you for the fast reply. Have a look at the search bar in my 404 page: http://www.webbix.es/en/dddlkjd.
    The search bar there is not working because in the url it will add an extra "/en/" as language code leading to repetitive 404.

    Regarding qTranslate I don't get any messages like in your case. I tried deactivating qTranslate and I still only can edit pages or posts in text (html) format and cannot choose the "wyswg" option that use to be there before. I am running last version of qTranslate.

    Thank you

  7. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    So why do you think this issue/problem is being caused by BPS?

    Have you put your website in Default Mode to eliminate that BPS is causing this problem?

    1. Make a backup of your .htaccess files using BulletProof Security built-in Backup.
    2. Activate Default Mode on the Security Modes page.
    3. Use the Delete wp-admin .htaccess feature on the Security Modes page.
    4. Test your plugin or theme.

    Upgrade to the new version of qtranslate. There is a known problem with the last version of qtranslate and WordPress 3.5.1 that is most likely the cause of this problem.

    FYI - If you are going to downvote a plugin you should probably get the answer from the plugin Developer before trashing the plugin. Most plugin authors would just ignore you for doing this, but I assume that you downvoted because you were upset so I do not take it personally. Thanks.

  8. simonysandra
    Member
    Posted 1 year ago #

    Hi.

    I have uninstalled and followed your instructions above but for some reason the page and posts edit still is not working how it should.

    I am trying to reinstall wp. let's see if this helps.

    thank you

  9. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Also you need to install the latest version of qtranslate. There is a known issue with older versions of qtranslate and WP 3.5.1.

    The other thing you need to check is your WordPress Permalinks settings. Does this type of URL language structure require some sort of custom permalink structure of Category base (permalink base). Does the qtranslate plugin create htaccess code to rewrite URLS with either /en/ or other URL paths?

    I do not use qtranslate and barely know how it works so you should probably check with the qtranslate plugin author about this issue/problem.

  10. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Also there is a plugin called Pages Links To: http://wordpress.org/extend/plugins/page-links-to/ by Mark Jaquith that will allow you to add your own URL linking structure/point a page to any page. If you have some kind of fubar URL structure then this plugin will correct your mistakes.

  11. simonysandra
    Member
    Posted 1 year ago #

    Okay. Now i got a solution for the search error: I just selected the option in qtranslate to not show the language code /en/ on the language you are in. this way no extra letters are added to the url.

    And I found out what the other thing was and it had nothing to do with BPS. I am very sorry and feel a bit ashamed for such a stupid mistake: I had marked by mistake not to show wyswyg for my specific user...

    Thank you a million for your support. It was awesomely fast.

    Now I have reinstalled BPS and everything is fine again.

    And if anyone has an issue with qTranslate and search query now we now a solution

    :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic