WordPress.org

Ready to get started?Download WordPress

Forums

Bitcoin Payments for WooCommerce
QR code link without "bitcoin:" (3 posts)

  1. Qjuf
    Member
    Posted 11 months ago #

    In browser (Opera, Explorer, Chrome) when I placed order i see QR code that i can click. But the link looks like : http://bitcoin adress..
    In the settings i see also: <a href="//{{{BITCOINS_ADDRESS}}}?.........
    and the most interesting fact that i see <a href="//{{{BITCOINS_ADDRESS}}}?........ in gray field next to field that i can change..??

    But it should be: <a href="bitcoin://{{{BITCOINS_ADDRESS}}}?

    I am trying to add "bitcoin:" before //{{{BITCOINS_ADDRESS}}}? in settings but it disappear after i save it. ???

    In bwwc-bitcoin-gateway.php i see correct line <a href="bitcoin://{{{BITCOINS_ADDRESS}}}?... and I have ho idea how is it cuted and by whom.

    Any ideas?

    http://wordpress.org/plugins/bitcoin-payments-for-woocommerce/

  2. oraclealchemist
    Member
    Posted 8 months ago #

    I'm having this same issue. I tried changing it in the file and on the page, but it keeps stripping out "bitcoin" in the href section. I'm not sure if this is a WordPress thing or this plugin.

  3. oraclealchemist
    Member
    Posted 8 months ago #

    Aha! I think I found the problem. WP limits allowed protocols in their clean_url function. You can disable the function or add the bitcoin protocol!

    http://wordpress.org/support/topic/external-protocols-in-blogrolllinks-manager?replies=5

    I was able to change it on WordPress 3.5.2 by changing line 3749 of wp-includes/functions.php to:

    $protocols = array( 'http', 'https', 'ftp', 'ftps', 'mailto', 'news', 'irc', 'gopher', 'nntp', 'feed', 'telnet', 'mms', 'rtsp', 'svn', 'tel', 'fax', 'xmpp', 'bitcoin' );

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.