WordPress.org

Ready to get started?Download WordPress

Forums

Push Syndication
Push Syndication (10 posts)

  1. Mark de Scande BlogLines
    Member
    Posted 1 year ago #

    Hey guys

    First of thank you :)

    I have tryed to set this up on the bloglines.co.za system

    The only thing i have not done is
    define('PUSH_SYNDICATION_KEY', 'this-is-a-randon-key')

    This is not clear to me as where must i add it and were must i get the this-is-a-randon-key :)

    BlogLines.co.za runs multi site / multi domain / domain mapping and shar DB 4096 + 2.

    The problem is it is not posting to the sites

    It is making everything has the meta boxes you name it it is all there it just don't want to post to the sites

    I have looked in the err logs and for the life of me i don't pick up any errs.

    So my question is the plug compatible with shar db ?

    My server is a open book please guys give me a hand to make this work.

    Thank you Kindly
    Mark

    http://wordpress.org/extend/plugins/push-syndication/

  2. Prasath Nadarajah
    Automattician
    Plugin Author

    Posted 1 year ago #

    The random key is used to encrypt passwords when saving to the database. You can define it in the wp-config.php file and it can be anything that is known to you.

    example:
    define('PUSH_SYNDICATION_KEY', 'mark-de-scande')

    You must define sites you want to push(Sites -> Add Site) and you can see whether the connection to the site is successful when saving the site. You must assign the sites to a sitegroup.

    I haven't tested this plugin sharedb.

  3. Mark de Scande BlogLines
    Member
    Posted 1 year ago #

    Ok Don't copy and past :)

    define('PUSH_SYNDICATION_KEY', 'mark-de-scande')
    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

    I then had a look and i see i was missing the last part ;
    define('PUSH_SYNDICATION_KEY', 'mark-de-scande');

    I will test it again and let you know

    Thank you Again for the help.

  4. Prasath Nadarajah
    Automattician
    Plugin Author

    Posted 1 year ago #

    I am sorry there is a typo in the instructions.
    It should be

    define('PUSH_SYNDICATE_KEY', 'mark-de-scande')

  5. Mark de Scande BlogLines
    Member
    Posted 1 year ago #

    Ok

    The bad news is i get Connection Successful! but it still is not posting.

    Looking at the err logs i dont see a bug.

    Can you maybe let me know where to dig ?

  6. Prasath Nadarajah
    Automattician
    Plugin Author

    Posted 1 year ago #

    After setting up a site you must assign it to a sitegroup. When publishing a post you must tick the sitegroup which have the sites you want to push.

    There may be multiple reasons for not posting including
    * You don't have sufficient permissions
    * XML-RPC not enabled
    * wp-cron may have issues firing in your host environment. You need to check whether the cron is firing. Try using the developer plugin.

    unfortunately the this version don't give sufficient feedback to the user whether the push is successful or not. The error sites are logged and it try to push in the next publish.

    If you give more details i can see what went wrong.

  7. Mark de Scande BlogLines
    Member
    Posted 1 year ago #

    The Server Killer wp-cron....

    I have disabile this site wide on BlogLines.co.za as wp-cron is a server hog.

    I have it set up running with WP-Cron Control..

    I will try the developer plugin now and give you some feed back.

    Thank you again for helping.

  8. Mark de Scande BlogLines
    Member
    Posted 1 year ago #

    Hey Guys

    I was looking at the code

    // firing a cron job
    	    add_action( 'transition_post_status', array(&$this, 'schedule_syndicate_content_cron') );
    	    add_action( 'syn_syndicate_content', array(&$this, 'syndicate_content') );
    	    add_action( 'syn_delete_content', array(&$this, 'delete_content') );

    This will never work on BlogLines.co.za or any systems were wp-cron is disabiled sucks sucks :(

    I have this line in wp-config

    define( 'WP_CRON_CONTROL_SECRET', 'boho' );
    define('DISABLE_WP_CRON', true);

    If you guys can think of a way for a workaround on this please let me know.

    Thank you Kindly
    Mark

  9. hypershock
    Member
    Posted 1 year ago #

    Mark you could add those actions to anything you have that autofires, it in theory should work for you.

  10. Mark de Scande BlogLines
    Member
    Posted 1 year ago #

    @hypershock i have dump the plug from the BlogLines.co.za system.

    Will give it a try again

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic