WordPress.org

Ready to get started?Download WordPress

Forums

[Pugin: All in One SEO Pack] Meta description doesn't showing in search engine (2 posts)

  1. svibor
    Member
    Posted 8 months ago #

    Hello.

    I'm beginner in Wp, so I apologize if this is "stupid" question. Every advice will be very helpful.

    In All in One SEO Pack, General settings I filled in "Home description" and "Home keywords (comma separated)". Home description consists of 23 words and 158 characters (with spaces). Home keywords (comma separated) consists of 42 words and 369 characters (with spaces). Other options I lefs as they were by default.
    In WordPress dashboard - Pages - on my homepage I put the same SEO Title, SEO Description and SEO Keywords as in ALL in One SEO Pack, General settings. On my other pages I left these fields blank.
    When I look for my page in search engine, it doesn't show my meta description, but show short welcome text that I put on my homepage.
    Can someone help me? I don't know what I'm doing wrong..

    Thanks!

  2. kenneth.von.rauch
    Member
    Posted 8 months ago #

    For starters, you may want to wait for a month or two to see if your changes take effect. Secondly, Google takes that info as a guideline, but they never promised that they will use your metadata just like you put it :) Sorry, that's how the Google cookie crumbles.

Reply

You must log in to post.

About this Topic