WordPress.org

Ready to get started?Download WordPress

Forums

Publishing Post Gives me Error Message (5 posts)

  1. jackburton
    Member
    Posted 8 years ago #

    Hey guys, just upgraded to 2.0, and here's the second problem I'm having:

    After I write a post and press save, WP publishes the post just fine, but it gives me an ERROR page, saying this:

    Warning: weblog_ping(/MYDOMAINNAME/wp-includes/class-IXR.php): failed to open stream: No such file or directory in /MYDOMAINNAME/wp-includes/functions.php on line 843

    Warning: weblog_ping(): Failed opening '/MYDOMAINNAME/wp-includes/class-IXR.php' for inclusion (include_path='.:/usr/share/pear') in /MYDOMAINNAME/wp-includes/functions.php on line 843

    Fatal error: Cannot instantiate non-existent class: ixr_client in /MYDOMAINNAME/wp-includes/functions.php on line 846

    Which is really odd, becuase, as I said, the post shows up just fine on the main page.

    Any thoughts?

  2. jackburton
    Member
    Posted 8 years ago #

    Nevermind, guys, figured out how to fix this one, too.

  3. moshu
    Member
    Posted 8 years ago #

    For the next poor guy having the same problem it would be really great if you could post what was the solution.
    Thank you :)

  4. jackburton
    Member
    Posted 8 years ago #

    Okay.

    Well, it kept looking for the "class-IXR.php" file, as indicated in the function.php, but I have my ftp set to change all capital letters to lower case when I upload files (for easier management). So I just changed the "class-IXR.php" in function.php to "class-ixr.php". Or I could have changed the file to the capital letter, but I prefer to keep them all lower case.

  5. bestfoot
    Member
    Posted 7 years ago #

    Thank you me as it happened again in another install. Why have upper and lower case file names anyway?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.