WordPress.org

Ready to get started?Download WordPress

Forums

"Publish" not an option (6 posts)

  1. mkirkwag
    Member
    Posted 4 years ago #

    I know this is dumb. I've chosen a setting somewhere to make the website private while I'm working on it, but now I can't find the darned setting, and the only option in my post is "Save Draft" and "Preview. The only choices in the status drop down are "Pending Review" and "Draft." Visibility is "Public" and "Publish Immediately" is set...so why the heck can't I publish my changes?

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    I've chosen a setting somewhere to make the website private while I'm working on it

    That shouldn't affect your ability to publish pages or posts. Check your user role/status. I think you're logged in as an author or contributor rather than an admin or editor.

  3. mkirkwag
    Member
    Posted 4 years ago #

    Nope, I'm an admin. That dawned on me after I posted. But here's something: "Publish" pops up for just an instant when I click "save draft." It shouldn't even be "publish" - it should be "update post."

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  5. mkirkwag
    Member
    Posted 4 years ago #

    Yep, you're right. It's a plug-in. I hadn't thought it was a "problem" but a "setting" so I hadn't even tried that. I was thinking "upgrade." Thanks for cleaning my windshield!

  6. mkirkwag
    Member
    Posted 4 years ago #

    The culprit seems to be SeoCare, by the way - in case anyone else is having a problem.

Topic Closed

This topic has been closed to new replies.

About this Topic