WordPress.org

Ready to get started?Download WordPress

Forums

Publish, Categories, Post Tags and Featured boxes now missing (7 posts)

  1. johnferris
    Member
    Posted 3 years ago #

    Hi, I had some malware on some of my WordPress sites this morning – most were add ins to files like custom.js jquery.js etc. But now since removing the offending single line of code from the files and replacing, the Publish, Categories, Post Tags and Featured image boxes which normally appear on right-hand side of the page when I add a new post have disappeared. I've tried the update to 3.0.2 but it hasn't made any difference. Anyone else experience this or know how to fix?

  2. David Gard
    Member
    Posted 3 years ago #

    I'd start by backing up your theme, plugins and database and then do a complete reinstall of WP. I'd imagine that updating only replaces files that have been edited, and it is possible that more files than you realise were affected.

    After that, restore you DB, add you theme and start the plugins 1 by 1, ensuring that all is fine. That should hopefully sort you out.

  3. johnferris
    Member
    Posted 3 years ago #

    :( that's the news I didn't want to hear! Six different sites all with customised themes!!

  4. David Gard
    Member
    Posted 3 years ago #

    It's really not as bad as it sounds, especially once you get used to the process. The only sad thing is that the results are not guarenteed, but by doing this you will at least have eliminated any infections from the WP Core. Why not start with just one, see if it works?

  5. johnferris
    Member
    Posted 3 years ago #

    Will give it a whirl. I officially hate Malware!

  6. johnferris
    Member
    Posted 3 years ago #

    Sorry to go back again but one more question – my site now seems to be giving a lot of permission errors, e.g. when I try and go to the configure page for All In One SEO Pack plugin or click on subscriptions (under tools menu) it has the "You do not have sufficient permissions to access this page." message coming up. Could the inability to show the screen options tab be related to a permissions problem?

  7. johnferris
    Member
    Posted 3 years ago #

    For anyone else who has had this problem the issue actually ended up being that the .htaccess file had been changed and parts deleted, I'm assuming by the Malware. But MediaTemple were very helpful in sorting quickly for me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.