WordPress.org

Ready to get started?Download WordPress

Forums

Publish button replaced by Submit for Review after 3.3 upgrade (14 posts)

  1. jzgpe
    Member
    Posted 2 years ago #

    After upgrading from 3.2.1 to 3.3, the "Publish" button on the new posts screen has been replaced by "Submit for Review". Any time I select the "Submit for Review" or "Save Draft" button, I'm redirected to a screen that says:

    Are you sure you want to do this?

    Please try again.

    "Please try again." is a link that takes me back to an empty "New Post" screen. Any text I may have entered is gone.

    I can add and delete users, links, and such. But I cannot publish or save new posts. So it seems the DB connectivity is fine.

    All this is true while logged on as Administrator.

    I've scoured the forums and tried every suggestion for resolving this issue to no avail. Disabling/enabling plugins didn't work. Futzing with the plugins directory didn't work. Adding a new admin user and adjusting the roles back and forth didn't work. There is plenty of space for the database. I've even tried a fresh install (that reads the existing 3.3 database). WP-Debugger didn't find anything wrong (technically, this plugin isn't compatible with 3.3). Nothing has resolved this issue.

    Any suggestions would be appreciated.

  2. Peter
    Member
    Posted 2 years ago #

    Don't have any suggestions, but I have exactly the same issue.

    None of the suggestions I've seen on any of the threads have worked for me.

    I'd really like to find a solution rather than delete/reinstall the site.

  3. Peter
    Member
    Posted 2 years ago #

    UPDATE:

    I managed to solve my issue, by going into cPanel and clicking on

    MySQL Databases

    I then did a "Check DB" and saw that WP-POSTS table was corrupted. Then after I did the "Repair DB" option, the Publish button came back.

    Hope this helps anyone else with a similar problem.

  4. jzgpe
    Member
    Posted 2 years ago #

    The solution to this issue wasn't easy and I did as much experimentation and investigation into the issue as I had time for. In the end, this is what I ended up doing:

    1. Export the existing data
    2. Copy existing WordPress directory to a backup location
    3. Drop the existing WordPress database
    4. Create a fresh install of WordPress 3.3 with identical settings as 3.2.1 site
    5. Before logging on to the new site for the first time, import the data from the following core tables only:
      • wp_commentmeta
      • wp_comments
      • wp_links
      • wp_postmeta
      • wp_posts
      • wp_term_relationships
      • wp_term_taxonomy
      • wp_terms
    6. Copy over templates, content, and plugins from backup site
    7. Log into new 3.3 site and finish up resetting the site as needed

    Once completed, I had a functioning site again.

    The issue was somehow related to the other core tables. However, checking the tables five ways from Sunday didn't reveal any database related issues such as corruption or index problems.

    This issue is definitely related to the 3.3 upgrade from 3.2.1. Just prior to the upgrade, I could publish posts. Immediately after the upgrade, the issue described in this ticket was in place.

    A final note: This is a WordPress site hosted on my own server. For security, I don't use tools such as webadmin, cPanel, or phpmyadmin.

  5. plumcreek
    Member
    Posted 2 years ago #

    I'm having this issue as well. Big fat pain. I'm guessing I'll have to go the re-install route, since nothing else I've tried has worked. This is NOT how I wanted to spend the next couple of days.

  6. plumcreek
    Member
    Posted 2 years ago #

    I was able to find a fix for my blog which was really easy.

    In the my.cnf file (the MySQL configuration file), I had

    sql_mode = TRADITIONAL

    Removing that and then restarting MySQL (actually MariaDB in my case) fixed the issue.

  7. TycksGirl1
    Member
    Posted 2 years ago #

    I managed to solve my issue, by going into cPanel and clicking on

    MySQL Databases

    I then did a "Check DB" and saw that WP-POSTS table was corrupted. Then after I did the "Repair DB" option, the Publish button came back.

    Yes this solved my issue also. Thank goodness. I have 20 WP sites and most upgraded to the newest WP update just fine but a few did not.

    Thank you.

  8. harmanrainu
    Member
    Posted 2 years ago #

    @Peter thanks man!
    only thing that worked on my site http://crazytouristguide.com/ :)

  9. CrushIQ
    Member
    Posted 1 year ago #

    Hi I am not quite as familiar with wordpress but am experiencing the same problem. Where can I navigate to the cPanel to find MySQL databases?

  10. Peter
    Member
    Posted 1 year ago #

    CrushIQ, as already mentioned, in cPanel, you need to scroll down to the section titled "Databases" and then click on the icon that says "MySQL Databases"

  11. CrushIQ
    Member
    Posted 1 year ago #

    Hi, I'm sorry I am not very familiar with wordpress. How do I access my cpanel. I know it is not in the admin login area but I do not know how to navigate to it. Thanks for the help

  12. fonglh
    Member
    Posted 1 year ago #

    cpanel is not in WordPress, login to your host's management console.

  13. Peter
    Member
    Posted 1 year ago #

    You access cpanel via your web hosting provider.

    Most providers use cpanel, but there are some notable exceptions like GoDaddy that use their own admin interface.

  14. drastikone1
    Member
    Posted 1 year ago #

    okay I don' have Cpanel. I'm with 1and1.com. They have a edit for the mysql database I setup. how would I fix this issue with 1and1.com in other words once I'm in my database management area. How do I fix this? I don't have much experience messing with the database and etc.

    Josh

Topic Closed

This topic has been closed to new replies.

About this Topic