WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Publicize not showing thumbnails (21 posts)

  1. ThatRuled
    Member
    Posted 1 year ago #

    I use two plugins, Facebook Like Thumbnail and Default Thumbnail Plus, to manage my post thumbnails.

    All sharing apps work great on Facebook, EXCEPT Pulicize - the thumbnails don't work. I've tried clearing all caches, regenerating the thumbnails, and even refreshing the pages via a debug for facebook.

    I'm at a loss. How can I get Publicize to recognize the thumbnails the same way every other type of share does?

    http://wordpress.org/extend/plugins/jetpack/

    [No bumping, thank you.]

  2. ThatRuled
    Member
    Posted 1 year ago #

    I just applied the new update, and it still isn't working. You guys did a lot of work on the other bugs, so, I'm not complaining that the update didn't fix it - just making the problem current.

  3. mashupciti
    Member
    Posted 1 year ago #

    I'm having the same issue.

    Putting an image in the 'feature image' or in custom fields, the image is not displayed in social media posts.

    The only way I can get images to publish to FB, is if it is inserted in the post which breaks blogging format.

    Other than that, IT'S FRICKEN AWESOME.

  4. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    Jetpack doesn't specifically work "with" these other plugins, so it sounds like there's probably a conflict between them, and how Jetpack tries to supply information to Facebook.

    What happens if you disable those other plugins and try just using Jetpack?

  5. ThatRuled
    Member
    Posted 1 year ago #

    The same thing, Beau. I'm going to raise an "invalid argument" flag on that, because Jetpack's own other sharing buttons CAN see the thumbnails. It's exclusive to the Publicize feature.

  6. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    Can you point me to an example URL where this happened?

  7. ThatRuled
    Member
    Posted 1 year ago #

    Absolutely! :)

    https://www.facebook.com/thatruled

    Take a look at the two most recent posts, both of which were pushed by WordPress' Publicize feature.

  8. mashupciti
    Member
    Posted 1 year ago #

    Well for me, here is my original post;
    http://www.mashupciti.com/mashup-music/jump-around-the-new-reptile/

    And here it is showing up on my FB page feed;
    http://www.facebook.com/themashupciti

    No images are displaying on the FB post. You can see a history of past posts doing the same.

  9. ChimpanzeeUK
    Member
    Posted 1 year ago #

    I too am having this problem. I set a og:image and image_src in the <head> of every post page and when I share it manually facebook obeys this and uses it as a thumbnail, but when a post is shared by Publicize it doesn't get picked-up.

    Any way to fix this?

  10. ThatRuled
    Member
    Posted 1 year ago #

    I also want to make it clear that this is easily the best new feature of Jetpack in a long, LONG time. This, at worst, is a cosmetic annoyance. Hope it gets fixed soon. Also, I'm glad it isn't just me. :)

  11. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    Can you all please check your *next* published post (after now) and let me know if it still happens?

  12. ThatRuled
    Member
    Posted 1 year ago #

    Just ran a test post - same issue:

    https://www.facebook.com/thatruled?ref=hl

    "TEST ONLY"

    :/ I really, really appreciate that you guys are working on it, though. Thank you x1000.

    I'll run post tests as much as you need.

  13. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    @ThatRuled -- did you delete the post immediately? I need to be able to see the page on your actual site to see what's going on unfortunately.

    Also, I noticed in one of your posts (http://www.thatruled.com/skeletroys-2013-schedule-january-to-june/) you have an og:image tag in the output that appears to be set by a different plugin (not Jetpack). The URL for the og:image is http://www.thatruled.com/wp-content/uploads/2012/10/SkeleBox-150x150.jpg

    I'm not sure how that is being set, but in the case of Publicize, the OG tags are not actually used, a specific image is referenced when posting to Facebook (which is determined based on the content of the post). The URL referenced above doesn't appear within the post, so it's not going to be available to Publicize (unless it's perhaps a Featured Image?)

  14. ThatRuled
    Member
    Posted 1 year ago #

    Whoops! Sorry! :( I went ahead and published something new that will stay up for troubleshooting.

    I use Default Thumbnail Plus to manage the thumbnails, and facebook references those specified images for every other type of sharing I can find.

    Reference:
    This post:
    http://www.thatruled.com/kthxdie-7-canada/

    https://www.facebook.com/thatruled

    Shows that the native sharing for Jetpack shows the thumbnail, but not the Publicize feature. So, Jetpack's native manual sharing buttons recognize the thumbnails (although I have no idea what tags that uses).

  15. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    OK, it definitely appears that that's the problem.

    The way you're setting the thumbnail, it's being embedded in the page using Open Graph tags. That's fine for any "normal" sharing method, but doesn't work for Publicize, because it needs to send a reference to a specific image to FB at the time of publishing. It only knows about images which are attached to/embedded within a post, and also featured images (whether they're inside the post or not).

    As long as your theme doesn't display Featured Images in some weird way, I believe you should be able to set the Featured Image of a new post to the image you want, and Publicize will use that successfully.

  16. ThatRuled
    Member
    Posted 1 year ago #

    While I certainly cannot ask you to fundamentally change the way the feature works to accommodate the plugin I use, can you suggest a way to set default featured images by category or author?

    I have six contributors putting up dozens of posts at all hours of the day, seven days a week. I'm looking to automate the process as much as possible, particularly with regard to sharing posts. The thumbnails, as you know, are a huge part of that.

    I have found no solutions, except for Default Thumbnail Plus. If I have to change how I do the thumbnails to make Publicize work, so be it, but manually adding the SAME thumbnail every time is just counterproductive.

    I heartily and humbly welcome suggestions. I am so close to full automation on this, and this is the final step.

    Thank you so much for all you do. It is appreciated.

    EDIT: I forgot that Featured Images change the header when you view posts.

    You know, I may just have to abandon the Publicize feature if there's no way around using a feature image (as inserting the same image inside multiple posts by author or category is simply not a feasible solution).

  17. ThatRuled
    Member
    Posted 1 year ago #

    Just adding this for anyone with the same problem:

    This plugin:
    http://wordpress.org/extend/plugins/add-link-to-facebook/

    Fills the gap with Publicize. I left the other Publicize functions running, and simply disabled the Facebook connection. Everything works together quite smoothly.

    If Publicize gets to a point where I can use it with my chosen thumbnail management system, I'll be back in a heartbeat - I LOVE it.

  18. acebrickman
    Member
    Posted 1 year ago #

    I have had a similar issue with Publicize, but even with my 3rd-party thumbnail generator plugin disabled (mine is "Video Thumbnails" Version 1.8.2 by Sutherland Boswell) the same effect is noticed on Facebook:

    http://faithcomm.com/2012/12/10/wpadmintest/

    you can see the "Publicize"-d posts here (see posts from 12/7/2012 through 12/10):
    https://www.facebook.com/faithcomm

    Now the test post (in addition to a few others on our page since I set up Publicize) with a defined featured image however we heavily utilize video posts as well, so creating a "featured image" utilizing the youtube preview capture without using an installed 3rd-party plugin would be AWESOME. Thanks!

  19. acebrickman
    Member
    Posted 1 year ago #

    This latest Jetpack update (2.0.4; cannot locate a Publicize version) appears to have resolved this issue for me. Thank you if you had any hand in it!

  20. chrishancockjr
    Member
    Posted 1 year ago #

    This update has not changed the issue for me.

    The theme I use won't allow me to attach a feature image to use as the thumbnail, it ends up getting posted allow with the video in the post.

    I'd rather not have to use another plug in to post to facebook but I guess I'll have to until publicize corrects the issue.

  21. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Facebook now uses the Open Graph meta tags to grab an image for all Publicized posts.

    Jetpack automatically adds Open graph meta tags, and will add an image tag if you have inserted images that were large enough (at least 200px x 200px) in your post.
    However, if you use another plugin to manage Open graph meta tags, the Jetpack tags will disappear and you will have to rely on the other plugin to provide an image tag for Facebook.

    You can check the Open graph meta tags associated to your posts thanks to the Facebook Debugger:
    https://developers.facebook.com/tools/debug

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic