WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Publicize not posting to Facebook (8 posts)

  1. wjackman
    Member
    Posted 8 months ago #

    This seems to be a common problem with the update to 3.8. Posting to Facebook does not work, and disconnect/reconnect does not help. I also tried deactivating/reactivating Jetpack. The problem began as soon as I updated to WordPress 3.8.

    I have also noticed that the "Publicize" widget is also not placing sharing buttons on my blog either, though I've tried to get that to work also.

    My blog site is http://www.limulussystems.com/blog/ if that helps solve the problem.

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 8 months ago #

    I had a look at your Jetpack settings, and everything seems to be set up properly. Publicize is also properly triggered.

    Could you let me know what other plugins you use on your site? One of them might conflict with Jetpack.

    I have also noticed that the "Publicize" widget is also not placing sharing buttons on my blog either, though I've tried to get that to work also.

    Jetpack's sharing buttons seem to be displayed properly on my end; I assume you've managed to activate them on your own:
    http://i.wpne.ws/T2zK

  3. wjackman
    Member
    Posted 8 months ago #

    Thanks for the help. I took a look at my blog on another computer and saw the sharing buttons that way; it must be that they don't show up when logged into the blog as an admin.

    The plug-ins that are currently activated are:
    Akismet
    All in one Favicon
    All In One SEO Pack
    Dagon Design Sitemap Generator Plus
    Extended Comment Options
    Fast Secure Contact Form
    Google XML Sitemaps
    IntenseDebate
    Jetpack by WordPress.com
    podPress
    Polldaddy Polls & Ratings
    Quick Adsense
    Twitter Follow Me Box
    Ultimate Google Analytics
    VideoPress
    WordPress Hashcash
    Wordpress Video Plugin
    WP-DBManager

    As I look at the list, I suppose I could eliminate some of them; a number were put in before Jetpack came along.

  4. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 8 months ago #

    I had a ook at your site, and I passed one of your posts through Facebook's debugger:

    https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.limulussystems.com%2Fblog%2F2013%2F12%2F19%2Fhelp-for-the-holidays%2F

    There are several errors there. Your site isn't outputting the needed og meta tags needed by Facebook. You have Al in One SEO installed and active, but you didn't configure the Social Settins to output the needed tags. Because that plugin is active, though, Jetpack won't output the tags either. I suspect that this is why your posts aren't being Publicized; we think Facebook has been getting stricter with missig og tags. Can you either configure All in One SEO properly, or deactivate it and let Jetpack output it's tags, then try the Debugger again. If you don't get any warnings or errors, then try writing a new post and see if it Publicizes. Let me know!

  5. wjackman
    Member
    Posted 8 months ago #

    You called it correctly - I needed to configure the Social Settings in All in One SEO. My blog posts are now appearing in Facebook the way they used to. Thank you very much for the assistance and consider this problem solved.

  6. besi1988
    Member
    Posted 6 months ago #

    Hi , im having the same problem.

    What did you do in the All in One SEO cuz im trying to sort it out under Social Meta
    but nothing is working.

    Thanks a lot

  7. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 6 months ago #

    besi1988: You need to activate the right settings in the Social Settings section of All in One. You can ask for more assistance with it here:

    http://wordpress.org/support/plugin/all-in-one-seo-pack

    Also, if you want me to look at your site, could you please start your own thread, as per the Forum Welcome?

    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

  8. besi1988
    Member
    Posted 6 months ago #

    I think I sorted :-)

    Thank you very much for your reply .

    All the best

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.