WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Publicize - new window opens but contains same web site (10 posts)

  1. pwizard
    Member
    Posted 1 year ago #

    Per @jeremy instructions to open new thread.

    When FB, TWITTER, etc is clicked, a new window opens, but it just basically my web site (same page) in a smaller window. The social media share windows don't open.

    see it at amindlesswasted dot com

    I had deactivated all my plugins and cloudflare, but no luck.

    (BTW, FB LIKE button does not work with Cloudflare, just shows loading. When i disable Cloudflare, that works.

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Have you tried to change your nginx configuration, as I mentioned in this thread?
    http://wordpress.org/support/topic/share-button-opens-post-in-new-window-but-doesnt-share?replies=5

  3. pwizard
    Member
    Posted 1 year ago #

    I don't even know what nginx is. I know we're on Apache. So I wouldn't know where to look for such code as suggested in that post.

  4. pwizard
    Member
    Posted 1 year ago #

    I don't even know what nginx is. I know we're on Apache. So I wouldn't know where to look for such code as suggested in that post.

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Something is a bit weird with your site configuration; your site configuration seems to go from nginx to Apache. I get 2 different responses for a similar request:

    http://i.wpne.ws/QHvz/content

    This might have something to do with CloudFlare. But since it doesn't help when deactivating CloudFlare, the problem must be coming from somewhere else.

    Do you use any plugins that may add some custom rules to your .htaccess file, or redirect pages including query strings? If so, could you try to deactivate them and let me know if it helps?

  6. pwizard
    Member
    Posted 1 year ago #

    I completely bypassed Cloudflare, set the nameservers back to host, cleared caches, deactivated every single plugin except Jetpack.

    The only lines in htaccess are

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    No good, problem still exists.

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you try to switch to a different theme for a few minutes, and let me know if it changes something?

  8. pwizard
    Member
    Posted 1 year ago #

    switched to default theme still no luck. BTW, I have had no problems with other social media plugins like Share This/Shareholic.

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    hm. That's interesting. Could you give me a list of all the active plugins on your site at the moment?

  10. pwizard
    Member
    Posted 1 year ago #

    This has been resolved. Rackspace told me there was a setting in Apache that was preventing htaccess to being read, thus killing permalinks.

    For anyone hosting on Rackspace that may experience this, added the AllowOverride option to the vhost

    thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.