WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Publicize giving error when adding accounts (32 posts)

  1. jim0thy
    Member
    Posted 1 year ago #

    Trying to add a connection to any social network results in the error:

    Error
    
    -32301: transport error - HTTP status code was not 200 (408)

    http://wordpress.org/extend/plugins/jetpack/

  2. matrover
    Member
    Posted 1 year ago #

    Same here,

    Got a HTTP-error 500
    using Theme Striking

    Twitter works do.

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @jim0thy
    Do you experience the same errors with the other Jetpack modules?

    @matrove
    Do you have access to your server's error logs? If so, could you search for the errors logged around the time when you experienced this 500 error, and paste that error here?

  4. jim0thy
    Member
    Posted 1 year ago #

    No, as far as I can tell everything else seems to be working fine.

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you let me know what's the URL in your address bar when you see that error message?

  6. jim0thy
    Member
    Posted 1 year ago #

    Sure, it's

    https://public-api.wordpress.com/connect/?jetpack=publicize&service=facebook&action=request&redirect_uri=http%3A%2F%2Fpensionledfunding.com%2Fwp-admin%2Foptions-general.php%3Fpage%3Dsharing%26action%3Ddone&for=publicize&siteurl=http%3A%2F%2Fpensionledfunding.com&state=1&blog_id=42215600&secret_1=EwytK2U5xMvCk8Jg4DN2JD0ybK72W19E&secret_2=nuJPS5lBpbSIDRqmcQUZiL2lKj2qbCfC&eol=1352912393

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks. It seems to be an issue with your hosting provider.

    Can you contact your hosting provider and explain to them that we are unable to access your blog via cURL, which is needed in order to use Jetpack.

    You can let them know we tried to access your site via cURL by running the following command:
    curl -i -H 'Content-Type: text/xml' --data '<?xml version="1.0&"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://pensionledfunding.com/xmlrpc.php'

    The cURL test returned the following invalid result:
    HTTP/1.1 408 Request Timeout

  8. jim0thy
    Member
    Posted 1 year ago #

    Interesting. When I try that command I get this result:

    HTTP/1.1 200 OK
    Date: Wed, 14 Nov 2012 16:59:18 GMT
    Server: Apache
    Connection: close
    Content-Length: 164
    Vary: Accept-Encoding
    Content-Type: text/xml
    
    <?xml version="1.0"?>
    <methodResponse>
      <params>
        <param>
          <value>
          <string>Hello!</string>
          </value>
        </param>
      </params>
    </methodResponse>
  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I tried once again, and I also get a 200 response now. Could you try to connect to Publicize again?

  10. jim0thy
    Member
    Posted 1 year ago #

    Nope, still getting the error

  11. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I am afraid there are still connection issues with your site. You can check it by entering your site URL in the Debug tool here:
    http://jetpack.me/support/debug/

    I would suggest that you contact your host about it.

  12. jim0thy
    Member
    Posted 1 year ago #

    The debug tool shows no problem connecting to the site.

    I get the message:

    Everything looks great!

    All tests have passed for pensionledfunding.com and your Jetpack powered site looks good to go!

  13. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    hm, interesting. Your site seems to be accessible at times, but not always. It still shows an error on my end right now.

    Could you contact your host, and ask them to double check that your site is always accessible?

    Thank you!

  14. matrover
    Member
    Posted 1 year ago #

    Sorry, it took me a while to get some logs but here they are:

    .204.46.63 - - [22/Nov/2012:20:29:26 +0100] "GET /wp-admin/load-scripts.php?c=1&load=jquery,jquery-ui-core,jquery-ui-widget,utils,thickbox,jquery-ui-mouse,jquery-ui-draggable,jquery-ui-droppable,jquery-ui-sortable,jquery-form&ver=3.4.2 HTTP/1.1" 200 61870 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:27 +0100] "GET /wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=2 HTTP/1.1" 200 38637 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:27 +0100] "GET /wp-admin/load-scripts.php?c=1&load=jquery-ui-tabs,admin-bar,hoverIntent,common,jquery-color&ver=3.4.2 HTTP/1.1" 200 9483 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:26 +0100] "GET /wp-content/plugins/page-tree/page-tree.css?ver=3.4.2 HTTP/1.1" 404 11305 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/sharedaddy/admin-sharing.css?ver=2.0.2 HTTP/1.1" 200 11359 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/publicize/assets/publicize.css?ver=20120925 HTTP/1.1" 200 3793 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/publicize/assets/facebook.png HTTP/1.1" 200 2265 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/publicize/assets/twitter.png?1 HTTP/1.1" 200 1331 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/publicize/assets/linkedin.png HTTP/1.1" 200 4130 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/publicize/assets/tumblr.png HTTP/1.1" 200 4861 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/publicize/assets/yahoo.png HTTP/1.1" 200 3697 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/sharedaddy/images/digg.png HTTP/1.1" 200 1700 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/sharedaddy/images/reddit.png HTTP/1.1" 200 1168 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/sharedaddy/images/stumbleupon.png HTTP/1.1" 200 888 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/sharedaddy/images/tumblr.png HTTP/1.1" 200 2192 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/sharedaddy/images/pinterest.png HTTP/1.1" 200 6659 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-admin/images/loading.gif HTTP/1.1" 200 2780 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /wp-content/plugins/jetpack/modules/sharedaddy/images/googleplus1.png HTTP/1.1" 200 824 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:28 +0100] "GET /favicon.ico HTTP/1.1" 200 191 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    81.204.46.63 - - [22/Nov/2012:20:29:30 +0100] "GET /wp-content/plugins/easy-fancybox/easy-fancybox.css.php?ver=1.3.4 HTTP/1.1" 200 8239 "http://www.vridos.nl/volleybal/de-teams/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    81.204.46.63 - - [22/Nov/2012:20:29:29 +0100] "GET /volleybal/de-teams/ HTTP/1.1" 200 44222 "http://www.vridos.nl/volleybal/jeugd/?preview=true&preview_id=1266&preview_nonce=52f676cd7f" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    81.204.46.63 - - [22/Nov/2012:20:29:30 +0100] "GET /wp-admin/options-general.php?page=sharing&action=request&service=facebook&kr_nonce=570bf59f28&nonce=62e566b76b HTTP/1.1" 302 759 "http://www.vridos.nl/wp-admin/options-general.php?page=sharing" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"
    72.232.7.46 - - [22/Nov/2012:20:29:32 +0100] "POST /xmlrpc.php?for=jetpack HTTP/1.0" 200 367 "-" "The Incutio XML-RPC PHP Library"
    81.204.46.63 - - [22/Nov/2012:20:29:42 +0100] "GET /volleybal/jeugd/ HTTP/1.1" 200 49165 "http://www.vridos.nl/volleybal/de-teams/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    81.204.46.63 - - [22/Nov/2012:20:29:43 +0100] "GET /wp-content/plugins/easy-fancybox/easy-fancybox.css.php?ver=1.3.4 HTTP/1.1" 200 8258 "http://www.vridos.nl/volleybal/jeugd/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    81.204.46.63 - - [22/Nov/2012:20:29:11 +0100] "GET /wp-admin/admin.php?page=stats&noheader&dashboard&width=1358 HTTP/1.1" 200 3561 "http://www.vridos.nl/wp-admin/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11"

    this happens when i try to make a connection.
    this is the acces log

  15. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @matrover Thanks. Unfortunately, there are no 500 errors listed there. Could you post the URL that appears in your address bar when you see that 500 error?

  16. matrover
    Member
    Posted 1 year ago #

    @Jeremy, thanks voor looking in to this problem.

    this is the url:
    https://public-api.wordpress.com/connect/?magic=keyring&service=facebook&action=verify&kr_nonce=f68f9f7eee&nonce=20d2440501&state=1829748&code=AQDS31uuo76i_nAAR8_jpxKKMNyOWgkYIWDDQqwQWn5PUXgT4UV0FcOjkoE-PedWawRcTTLnUX7JWHDX6lJBbmf8L6xB8mTH-Aslpl4Oq1ukArxMLq0tehLNNIvgh0z3umggSx8jjHYf93SPseTOJ3x6YIP7QHoBKSEuVTHmJB7seycZahAxWRPHmG3i3kYUddaTxIQDR2QVT87br9H8GLLX#_=_

  17. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks! Could you try to connect once again? it's worth noting that you will need to use a Facebook profile account to make the connection. A Page-only account can not be used with Publicize.

  18. jon_na_fun
    Member
    Posted 1 year ago #

    I'm also having this error. This is my url http://deedalstudio.com/wp-admin/options-general.php?page=sharing&action=error&publicize_error=-32301.

    The Facebook connection doesn't work now but the twitter connection still works.

  19. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @jon_na_fun Your Jetpack plugin may be missing some files. Could you delete all plugin files and reinstall again?

  20. jon_na_fun
    Member
    Posted 1 year ago #

    Hi, I've deleted all te files and reinstalled the plugin. Now both Facebook and twitter doesn't work. I can't post it to fb and twitter via your plugin.

  21. matrover
    Member
    Posted 1 year ago #

    @Jeremy, just tryed again, but same error, same url.

    my FB page is not my account but a page could that make a difference??

    Thanks!

  22. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @matrover You'll need to connect to your Facebook personal account instead. Once you have done so, you'll be able to choose whether you want to publish posts on your Facebook Wall, or on a Facebook Page where you are listed as a Page Admin.
    You can read more about it here:
    jetpack.me/support/publicize/#facebook

    @jon_na_fun I checked your Twitter account, and it seems to work properly now. Could you try to connect to your Facebook personal account again?

  23. matrover
    Member
    Posted 1 year ago #

    @jeremy, my bad, i will try it when im home.

    thanks

  24. jon_na_fun
    Member
    Posted 1 year ago #

    @jeremy how did you check my twitter account? When I try to connect my twitter and Facebook. I still get error 32301.

  25. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @jon_na_fun I just tried had a look at your XML-RPC file, and received a 408 - Timeout error.

    Your problem seems to be similar to jim0thy's.

    Could you contact your hosting provider about it, and give them the information I gave to jim0thy at the top of this thread?

    Thanks!

  26. matrover
    Member
    Posted 1 year ago #

    @jeremy, youre the man!

    worked like a charm!

    Thnx man

  27. hectorea
    Member
    Posted 1 year ago #

    I'm getting the following error in Sharing Settings in my WordPress site (http://hectorea.com/):

    Something which should never happen, happened. Sorry about that. If you try again, maybe it will work.

    Error code: -32700

    I haven't able to configure facebook, twitter nor linked in.

    Could you help please?

  28. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    it seems that your site is not properly connected to your WordPress.com account. This might be caused by some conflicts between Jetpack and your server settings.

    If you use Varnish and Nginx on your server, you might be able to solve the issue by following the steps described here:
    http://usefulmix.com/wordpress-nginx-varnish-jetpack-xml_rpc-32700-glitch-fix/

    If you use a different server configuration, could you let me know about it? Does your server use any kind of caching, or do you use a Firewall to protect your site?

    Thanks!

  29. InsightDezign
    Member
    Posted 1 year ago #

    Hi Jeremy,

    My turn. I'm getting the "Error code: -32301" when trying to connect to LinkedIn. I've tried clearing my cache, using different computers and using different browsers. The url is connected to WordPress.com with JetPack and I used the http://jetpack.me/support/debug/ page you suggested earlier in this thread and it says all is fine. I've also tried deactivating all other plugins and still get the same error. The last thing I tried was deleting all the plugin filed for JetPack and re-installing. Still no luck. Do you have any other suggestions?

    url: http://finseldercare.com/

    url with error: http://finseldercare.com/wp-admin/options-general.php?page=sharing&action=error&publicize_error=-32301

  30. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @InsightDezign

    Can you contact your hosting provider and explain to them that we are unable to access your blog via cURL, which is needed in order to use Jetpack on your site.

    You can let them know we tested the following:

    1. Check for access to xmlrpc.php via browser:
    http://finseldercare.com/xmlrpc.php

    That test returned "XML-RPC server accepts POST requests only." which is a valid result.

    2. Check for access via cURL by running the following command from the command prompt:
    curl -i -H 'Content-Type: text/xml' --data '<?xml version="1.0&"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://finseldercare.com/xmlrpc.php'

    The cURL test returned the following invalid result:
    HTTP/1.1 408 Request Timeout

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic