WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Publicize FB Posts Inconsistently Using Wrong Image (3 posts)

  1. wolfman9093
    Member
    Posted 10 months ago #

    I'm running a self-hosted wordpress.org blog (http://viterbiconnect.usc.edu/) and using publicize to share all posts on our facebook page (https://www.facebook.com/USCViterbiUndergrad).

    Recently Facebook has been using the wrong image in some post previews. I just want it to use the featured image. When the wrong image is used, it's always the same image from a 9/23 post, which is when this issue started.

    All my blog posts have featured image, and I've run a bunch of them through the facebook debugger (https://developers.facebook.com/tools/debug) and all of them have proper og:image metatags and are showing the correct image on the debug side but some are nevertheless displaying incorrectly on my page.

    I've read in some places that running posts through the debugger might clear the facebook cache, but I ran some of these through 6 days ago and no change has occurred.

    Example of a blog post which generated a correct preview: http://viterbiconnect.usc.edu/go-global-student-panel/?fb_source=pubv1

    Example of a blog post which generated an incorrect preview: http://viterbiconnect.usc.edu/mandatoryadvisement/?fb_source=pubv1

    I've looked at lots of similar threads (see below), but can't seem to make any progress.

    Similar threads:
    http://wordpress.org/support/topic/jetpack-publicize-creating-malformed-links-in-facebook

    http://wordpress.org/support/topic/featured-image-of-post-not-showing-up-when-publicized-to-facebook/

    http://wordpress.org/support/topic/featured-image-not-showing-up-when-publicized-to-facebook-continued

    Any help in even determining what could be wrong would be greatly appreciated! Thank you in advance for any advice!

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    When you share a post on Facebook, or when Jetpack Publicize publishes a post to your Facebook page, Facebook crawls the page and looks for Open Graph meta tags in the head to build a complete post preview (with an image, title, description, ...).

    As you mentioned, all your posts have the proper image tags, and the Facebook Debugger seems to recognize them. Running posts through the debugger will indeed clear the facebook cache, but that won't affect posts that are already published on Facebook; it will only update the image for people posting the link after you clear the cache.

    At this point, I'm afraid there is not much we can do on our end. Your posts include image tags, and it's up to Facebook to use these images or not.
    The issue might be linked to this Facebook bug:
    https://developers.facebook.com/bugs/483025408453290
    If in some of your tests you run into the "Provided og:image is not big enough" message, although your images are bigger, you might want to comment and vote on that bug to let the Facebook developers know about the issue.

    I hope this helps.

  3. wolfman9093
    Member
    Posted 9 months ago #

    Thank you very much for the follow up! I will look into that Facebook bug and hope for a fix on their end.

Reply

You must log in to post.

About this Plugin

About this Topic