WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
"Publicize" default when posting by email (7 posts)

  1. Neil Parks
    Member
    Posted 1 year ago #

    Site: http://wp.hjcs.org

    I want to have all posts automatically copied to Facebook and Twitter.

    Publicize: Facebook: Heights Jewish Center Synagogue, Twitter: @HJCS_613 Edit Settings

    We have made a few posts by email, and they are not showing up on F & T. I have read the documentation on using the "publicize" shortcode:

    (Quote)

    Changing your Publicize settings

    WordPress Publicize lets you notify other web services about your posts. With the [publicize] shortcode you can control this from emails.

    [publicize off] - disable all Publicize notifications

    [publicize twitter] - only send a notification to Twitter

    [publicize twitter]my new post[/publicize] - only send a notification to Twitter and set the Twitter status to my new post

    Note that your Publicize settings must have been previously configured.

    (End Quote)

    What is the default if there is no publicize shortcode in the post? I would have thought that it would default to the same setting as a post made online. But it seems that the default is publicize off. And if that is the case, the documentation ought to say so.

    ALSO; If I do need to specify F & T with shortcodes, do I use one entry or two? Would it be

    [publicize facebook twitter]

    Or do I need

    [publicize facebook]
    [publicize twitter]

    http://wordpress.org/extend/plugins/jetpack/

  2. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi! I will ask our Publicize expert, and get back to you. Thanks for the report!

  3. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi!

    Thanks to your questions, I have updated our support doc on the Post by Email feature:

    http://jetpack.me/support/post-by-email/

    The key bits, to answer your questions:

    • if you do not include a [publicize] shortcode in your email, and you have previously set up your Publicize options, your post will go out to all of your Publicize connections, as you suspected; if it isn't, then there is a problem that we need to investigate
    • if you want to include the Publicize shortcode to specify that it should go to only your Twitter and Facebook connections for example, you need to use [publicize twitter facebook]; if you include both [publicize twitter] and [publicize facebook] in the same email, the post will be publicized to only the second network included as a shortcode.

    I hope that clarifies things, and once again, thank you for your question!

  4. Neil Parks
    Member
    Posted 1 year ago #

    Hi Richard. Thanks for clarifying the doc file.

    Since the emails did not have a [publicize] tag, but did not go out to Facebook and Twitter, I guess we do need to investigate. What can I do to assist?

  5. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi Neil,

    Ok, so first, I'll ask you to try again, and let me know which post you've done it with, and to which Twitter and FB accounts it should have gone to. You can contact me at support@jetpack.me if you'd like to keep it private for now. If you do so, please link to this thread. Thanks!

  6. Neil Parks
    Member
    Posted 1 year ago #

    New problem: Now my online posts are not getting publicized. I tried disconnecting and reconnecting but it did not help.

    Accounts it should have gone to:
    Publicize: Facebook: Heights Jewish Center Synagogue, Twitter: @HJCS_613

    http://www.facebook.com/hjcs.613
    http://www.twitter.com/HJCS_613

    Online post that was not publicized:
    http://wp.hjcs.org/hjc-annual-book-sale-2/

    Recent email posts that were not publicized:
    http://wp.hjcs.org/pre-pesach-class-tonight-8pm/
    http://wp.hjcs.org/this-weeks-schedule/

    Last post that was successfully publicized was a test on Feb 26. It is still up on F and T, but not on the wordpress site.

  7. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Ok, so I noticed that the post that you refereed me to has a -2 in the URL. that often means that created a post or page with the same permalink; to avoid conflicts, WordPress will add a -2 to the newer post or page. That might have something to do with it (but I'm making an educated guess). Would it be possible to create an admin user for me so that I can log in and check things out for myself? If so, please send the info to support@jetpack.me and link to this thread, like I mentioned previously. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic