WordPress.org

Ready to get started?Download WordPress

Forums

public_html chmod to 750 (14 posts)

  1. carguyjay
    Member
    Posted 3 years ago #

    Hi Guys!
    I am trying to add just a little more security to my site and I read on some blogs that I should change my public_html from 755 to 750.

    Can someone please explain this to me.

    I understand that if I set it to 750 I will be blocking everyone from accessing my site. How can this possibly work. I did more research and someone told me that the folder public_html should be owned by me and the group "nobody" and then when I set the folder to 750 everything would be fine.

    Is the nobody group default? is there anything I have to do to the group itself?

    Does anyone actually know or have does this to their site?

    Thanks for your help
    Jay

  2. govpatel
    Member
    Posted 3 years ago #

    I think that is default on cpanel public_html is 750

  3. carguyjay
    Member
    Posted 3 years ago #

    Hi Govpatel
    Thanks for the reply.
    Who is your hosting with.

    Mine is with Godaddy and my default is 755 on public_html.
    When I change it to 750 my site goes to block everyone.

    Thanks
    Jay

  4. Samuel B
    moderator
    Posted 3 years ago #

    folders = 755
    files = 644

  5. MichaelH
    Member
    Posted 3 years ago #

    Not that I can really explain why, but as mentioned by govpatel, my host requires public_html to be 750.

  6. carguyjay
    Member
    Posted 3 years ago #

    Hi Samuel
    Yeap I got my
    folders at = 755
    files at = 644 ( but for the wp-config they want it at 640 )

    However after reading the hardening guide:
    It states that my (should be) public_html = 750
    and I just can't do that because it blocks the whole site. It has to stay 755.

    and

    wp-config (should be) = 640
    can't do this either because it too blocks my whole site. Is anyone else's wp-config = 640?

    How in the world is anyone else getting to set these settings without doing anything else on their server?

  7. carguyjay
    Member
    Posted 3 years ago #

    Hi MichaelH
    Thanks for the reply.
    Who's your host?

    and who is the group owner of your public_html?

  8. MichaelH
    Member
    Posted 3 years ago #

    I use A Small Orange that uses cPanel.

    Won't divulge group owner but it is not me.

  9. Samuel B
    moderator
    Posted 3 years ago #

    hey Michael - I use ASO, also and just noticed the public_html is 750 - all other folders are 755
    wp-config.php is 644

    owner is 32777
    group is 32329

  10. govpatel
    Member
    Posted 3 years ago #

    I am with GVO and I have always had public_html as 750 and folders as 755 and all files 644 and I changed my config file 640

    May be Go Daddy has their server set differently check with them and see what the norm is for settings.

  11. carguyjay
    Member
    Posted 3 years ago #

    Hi Guys
    Thanks for the replies, this is really helpful.
    I absolutely got a hold of GoDaddy before I posted and they are all set on the idea that if public_html is set to 750 you are giving access to the owner to the group and you are blocking the "world" with that zero setting. So they do not understand how the world is accessing the site if they do not have read access to it.

    Same thing goes for the wp-config my DB can't get to the file if its 640. But I bet you both these issues are from the same source.

    Here is how I installed my directories:

    home/username/public_html/ files
    I also tried
    home/username/public_html/wordpress/ files

    and both installations work the same way as in public_html is 755 and if its anything else its blocked. I can change it to 604 but thats the same idea as 755.

    Not sure where to go from here. I can't seem to find enough information regarding the process of setting public_html to 750 on the web. The only thing I hear is that allegedly the group owner has to be set to nobody (but that means nothing unless you know who the users are in the group)

    Thanks for your help guys!
    Jay

  12. MichaelH
    Member
    Posted 3 years ago #

    Might have to go with the settings your host requires.

  13. carguyjay
    Member
    Posted 3 years ago #

    So I called Host Gator
    Apparently they have 750 set to all public_html by default, however they would not tell me how their Apache server is set.
    The settings are the same on shared hosting and on VPS.

    It seems that Godaddy has their default public_html set to 755 for all VPS and shared hosting. I am trying to get more information from them but they seem clueless about this.

  14. carguyjay
    Member
    Posted 3 years ago #

    Took me forever but I figured it out!

    I am creating documentation and I will provide a link shortly!

    Thank you all for your contribution

    Jay

Topic Closed

This topic has been closed to new replies.

About this Topic