WordPress.org

Ready to get started?Download WordPress

Forums

"Psuedo-Subscribers" Unable To Use Network Sites (4 posts)

  1. Dreadknux
    Member
    Posted 3 years ago #

    Hi there, been looking forward to WP3 and so far getting to grips with the new settings.

    I've had a problem when it comes to establishing an integrated userbase across my networked websites under Multi-site. According to WordPress moderators, already-existing users on the base website should be able to log into all the sites on the network as a Subscriber. This is not happening for me.

    My base website is http://www.sonicstadium.org, which has a lot of users who registered pre-WP3. I am trying to log into a subsite, http://sega.sonicstadium.org, using a test account. This is what is happening:

    - Head to sega.sonicstadium.org, click Log In

    - Enter login credentials for 'test' account (registered at base website - http://www.sonicstadium.org) at http://sega.sonicstadium.org/wp-login.php

    - Redirected, without any sort of notification, to http://www.sonicstadium.org/wp-login.php (because the two login pages look the same, this will confuse users)

    - Enter login credentials (again) at the base website's login page instead. Successfully load wp-admin page.

    - Direct browser, after successful login, back to http://sega.sonicstadium.org. Sidebar once more asks me to Log In, and I am unable to comment or participate in activities enjoyed by Subscribers.

    Ignoring the fact that the redirect to the base website's login page isn't very user-friendly (despite it making sense to do so), it seems that what was said by WordPress moderators - that all users could access sub-sites using their base site's credentials as a 'psuedo-Subscriber' isn't working as well as it could be.

    Maybe I'm doing something wrong, but I hope someone in the know has the ability to make this work. About the only benefit in multi-site for me was the ability to integrate users, so it would be a bit crushing to have this feature not come to fruition.

    Thanks for your help in advance!

  2. Dreadknux
    Member
    Posted 3 years ago #

    Any ideas?

  3. - Direct browser, after successful login, back to http://sega.sonicstadium.org. Sidebar once more asks me to Log In, and I am unable to comment or participate in activities enjoyed by Subscribers.

    Yep, this is definitely the part that should work.

    Users should really log in to the main site first. Then going from site to site on the network, it should show them as already logged in.

    As the Super Admin, when you log in, can you move from site to site without logging in again?

  4. Rlyeh
    Member
    Posted 3 years ago #

    Hey,

    Same here - 2.9 site with many accounts, network built succesfully, but "old" users can't login to newly created site. Login at main site is however possible and works ok. For superadmin it works as intended (I think it works for Dreadknux as well).
    Type of multiinstall is "directory", and I'm testing this on localhost for now.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.