WordPress.org

Ready to get started?Download WordPress

Forums

Protected Pages Not Working (8 posts)

  1. SoundChaser
    Member
    Posted 5 years ago #

    I'm having a really, really rough time figuring this one out...although, that's not a surprise since I am a newbie to WordPress (but not to installing and configuring CMS's / blogs).

    I have a clean install of WordPress that I have done the following to:

    - Installed 2 themes (blocks and blueprint), and set the theme to blocks.
    - Changed the permalinks to Month and Name.
    - Made a few other smallish tweaks: blog title, blog tag, etc.

    I then tried to create a new page. I set the page as a Protected page with a password, turn off comments and pings.

    When I log out, and try to access the page via the permalink, I get a 404 error. If I am logged in, I can get to the page without a problem.

    I've done the following in trying to resolve this issue:

    - Wiped and re-installed WP. (At first I thought something else might have happened to the database.)
    - Changed back to the default permalinks.
    - Changed the theme (I've tried all four that are installed: blueprint, classic, default, and blocks).
    - Watched to make certain the .htaccess file is getting updated correctly when I change the permalinks.

    The weird part of this whole thing is that for a while, it was working correctly.

    Does anyone have any clues? Or maybe even a better process to go about debugging this issue?

    Thanks for any help!

    George

  2. yoshi
    Member
    Posted 5 years ago #

    Isn't the post by any chance set to private?

    Are you sure that:
    1. the post password is entered
    2. the post is published
    3. and the "Keep this post private" box is UNchecked?

  3. styleblo
    Member
    Posted 5 years ago #

    I think you forget to save and publish your page.

  4. SoundChaser
    Member
    Posted 5 years ago #

    stylebo: no, the page is saved & published.

    yoshi: I have the page set private -- because I don't want it listed on the menus. I didn't see anywhere in the documentation that suggested that the page isn't accessible when marked private...

    George

  5. yoshi
    Member
    Posted 5 years ago #

    Private Page is meant to return 404 because you don't want people to know the hidden page is there.

    If you want others to read the Page with the password, it shouldn't be private and you can remove the Page from the menus by setting 'exclude' argument in wp_list_pages.

  6. SoundChaser
    Member
    Posted 5 years ago #

    Yoshi,

    Then it needs to be documented better. It defnitely isn't clear that "private" pages are only accessible to authenticated users. In reality, what's the difference between a private page and an un-published page? From my understanding thus far, the only difference is that an un-published page can be scheduled to be published.

    I was aware of the exclude argument for the wp_list_pages function, however, that seems to be to be a rather hack-ish way to go about handling this. (Past experience: hard-coding things isn't a good idea.)

    This makes me think maybe there is a better way to do this: use the custom fields to add a value called, say, MenuDisplay, and set it True/False, then have a plugin to replace/supplement the built in wp_list_pages to query that field...

    George

  7. yoshi
    Member
    Posted 5 years ago #

    These things can be confusing. I agree that.

    what's the difference between a private page and an un-published page?

    Private posts are also hidden from other authors. If you are the only user of the blog, provably there aren't many situations to use private status.
    I also use private status for expired articles - which I want to keep for myself but don't want in the drafts list either.

    use the custom fields to add a value called, say, MenuDisplay, and set it True/False

    You can filter Pages by custom field.

    <?php wp_list_pages('meta_key=MenuDisplay&meta_value=1' ); ?>

  8. csinclair
    Member
    Posted 5 years ago #

    can you explain the exact implementation of the above.
    i put the code in, create a custom field key named "MenuDisplay" and then have typed True, TRUE, 1, and non of those values do the trick for my page. like the other above, i want to make pages that don't show up in my master menubar, then password protect them, so that when i email a friend the URL, he can type in the password and view content...without normal visitors having access or knowledge of the link. any help appreciated.
    ps. i have WP-PageNavi activated, but didn't know if that enabled certain code to work or not.

Topic Closed

This topic has been closed to new replies.

About this Topic