WordPress.org

Ready to get started?Download WordPress

Forums

Properly inserting HTML objects in a Post (6 posts)

  1. MattLawlis
    Member
    Posted 7 years ago #

    Hello,
    I'm trying to insert this code into one of my pages on my WordPress:

    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,47,0" width="30" height="30" id="wimpybutton661">
    <param name="movie" value="http://betchslap.com/media/ringtones/wimpy_button.swf" />
    <param name="loop" value="false" />
    <param name="menu" value="false" />
    <param name="quality" value="high" />
    <param name="bgcolor" value="#FFFFFF" />
    <param name="wmode" value="transparent" />
    <param name="flashvars" value="theFile=http%3A%2F%2Fwww%2Ebetchslap%2Ecom%2Fmedia%2Fringtones%2F%24300shoes%2Emp3" />
    <embed src="http://betchslap.com/media/ringtones/wimpy_button.swf" flashvars="theFile=http%3A%2F%2Fwww%2Ebetchslap%2Ecom%2Fmedia%2Fringtones%2F%24300shoes%2Emp3" width="30" height="30" bgcolor="#FFFFFF" loop="false" menu="false" quality="high" name="wimpybutton661" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" wmode="transparent" /></object>

    I entered it in the HTML area on the Write page, and it came out like this: http://www.betchslap.com/?page_id=28

    What can I do to make it work properly?

  2. vavroom
    Member
    Posted 7 years ago #

    Don't use the rich visual editor...

  3. MattLawlis
    Member
    Posted 7 years ago #

    I tried not using it, still looks that way.

  4. vavroom
    Member
    Posted 7 years ago #

    Run your site through the validator, fix the validation errors (44 listed), and you'll likely have solved your layout issue.

    For instance, you have the <html> tag in the middle of your page, unclosed <img> tags, missing <li>, object IDs repeated, no alt attributes for the img tag, etc...

  5. MattLawlis
    Member
    Posted 7 years ago #

    How do I run it through the validator? Oh, and my layout doesnt always look like that. Only on that page.

  6. vavroom
    Member
    Posted 7 years ago #

    http://validator.w3.org/ instructions are pretty clear there. it'll list errors, and explanations of said errors.

    chances are the stuff you are inserting on that page is what is breaking validation in some way.

Topic Closed

This topic has been closed to new replies.

About this Topic