WordPress.org

Ready to get started?Download WordPress

Forums

YOP Poll
[resolved] Program doesn't Validate (7 posts)

  1. goalcore
    Member
    Posted 6 months ago #

    Installed the program, it works. Great.

    BUT..

    It doesn't validate, has 2 errors and 1 warning.
    I don't know how to fix it. Any help?

    curtleaming@goalcore.com

    http://wordpress.org/plugins/yop-poll/

  2. YOP
    Member
    Plugin Author

    Posted 6 months ago #

    Hi goalcore,

    Based on the test we ran our plugin is fully compatible with WordPress 3.8
    Please provide more details regarding the errors you receive so we may assist.

    Regards,

    YOP Team

  3. goalcore
    Member
    Posted 6 months ago #

    yop-poll Errors after update

    Validation Output: 2 Errors

    Error Line 133, Column 140: Element style not allowed as child of element li in this context. (Suppressing further errors from this subtree.)

    …'s Poll</h3><style type="text/css">#yop-poll-container-2_yp52b1d6473d555 {

    Contexts in which element style may be used:
    If the scoped attribute is absent: where metadata content is expected.
    If the scoped attribute is absent: in a noscript element that is a child of a head element.
    If the scoped attribute is present: where flow content is expected, but before any other flow content other than inter-element whitespace and style elements, and not as the child of an element whose content model is transparent.
    Content model for element li:
    Flow content.

    Error Line 336, Column 166: Element link is missing required attribute property.

    …lugins/yop-poll/css/yop-poll-public.css?ver=4.8' type='text/css' media='all' />

    Attributes for element link:
    Global attributes
    href
    crossorigin
    rel
    media
    hreflang
    type
    sizes
    Also, the title attribute has special semantics on this element.

  4. YOP
    Member
    Plugin Author

    Posted 6 months ago #

    Hey goalcore,

    Do you have any other plugins installed?
    It would be helpful if you could create an account on your site for us so we may take a look and see exactly what causes the problem.

    You can email the access details at yop.office{at]gmail.com

    Best wishes,

    YOP Team

  5. YOP
    Member
    Plugin Author

    Posted 6 months ago #

    Hi Curt,

    We ran some tests and we could not replicate those errors.
    As far as we can see, our plugin works properly (please check your email, we attached some screenshots).

    Please send us screenshots of the errors you receive and tell us exactly when and how they occur.

    Regards,

    YOP Team

  6. goalcore
    Member
    Posted 6 months ago #

    I can't send a screen shot through this forum or at least I don't know how to do it. If you GO TO http://validator.w3.org/ and type in my site; http://www.goalcore.com you can run the test and see the errors first hand.

    Thank you
    Curt Leaming
    goalcore.com

  7. YOP
    Member
    Plugin Author

    Posted 6 months ago #

    Hi Curt,

    If you see those errors in the code validator does not mean that our plugin doesn't work properly. For example, the validator expects that the <style> should be defined in the header, which doesn't happen in WordPress.

    The W3C Markup Validation Service is helpful if, for example, you learn HTML or CSS and you want to verify the code you've written.

    In addition, as you can see, your site was tested as HTML5 markup. Our plugin is not HTML5 ready yet. Depending on the doctype you choose, you will get more or fewer errors.

    Best wishes,

    YOP Team

Reply

You must log in to post.

About this Plugin

About this Topic

Tags