WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
[resolved] profiles not working (2 posts)

  1. narlysoftware
    Member
    Posted 1 year ago #

    I've tried the following combinations and can not get the profiles to work. What is the correct method to get them to work

    I've tried:
    [gview profile="3" file="IRS Publication 502.pdf"]
    [gview file="IRS Publication 502.pdf" profile="3"]
    [gview file="IRS Publication 502.pdf", profile="3"]
    [profile="3"][gview file="IRS Publication 502.pdf"]
    [gview file="IRS Publication 502.pdf"][profile="3"]

    Please send an example.

    Thank you.

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    The order of attributes does not matter, but they must be all inside a single set of brackets. There are no commas. Thus either of these should work:

    [gview profile="3" file="IRS Publication 502.pdf"]
    [gview file="IRS Publication 502.pdf" profile="3"]

    ...since you're only using the filename and not a complete URL, the plugin is looking for the file at your "File Base URL" setting, which may or may not be correct. Try using the full URL if you're having problems.

    The full shortcode syntax is well documented. See here:
    http://www.davistribe.org/gde/usage/

    Also, you may consider renaming the file so that the filename does not contain spaces, which isn't standard convention on most web hosts. This isn't necessarily a problem, but replacing the spaces with underscores or hyphens would help eliminate that as a source of the issue.

    If you need help with specific files files on your site, use the Support tab in GDE Settings to send me debug information.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags