Ready to get started?Download WordPress


WooCommerce - excelling eCommerce
[resolved] Products per page won't change (12 posts)

  1. pennisol
    Posted 1 year ago #

    Trying to get at least 16 products on the category page. (4x4)
    I have made following changes already to functions.php

    // Change number or products per row to 4
    add_filter('loop_shop_columns', 'loop_columns');
    if (!function_exists('loop_columns')) {
    	function loop_columns() {
    		return 4; // 4 products per row
    // Redefine woocommerce_output_related_products()
    function woocommerce_output_related_products() {
    woocommerce_related_products(4,1); // Display 4 products in rows of 4
    add_filter( 'loop_shop_per_page',  create_function( '$cols', 'return 24;' ), 20 );

    For some reasons, I won't get more than 5 products per page (4 wide)

    see website here

    (WP multiusersite)
    (own custom theme with woocommerce plugin added.)

    any help would be appreciated.


  2. pennisol
    Posted 1 year ago #

    Something in my theme (a non-woo theme) is holding the max amount of products shown back to 5. Nevertheless in functions.php i'm asking for 24.

    When I switch to Wootique theme, all products are shown.

    Anybody who has an idea what is triggering this stop at 5 products in my custom theme?

  3. pennisol
    Posted 1 year ago #

    found it. a louzy little setting in the theme backend

  4. SummerN
    Posted 1 year ago #

    What did you find? Im having the same problem but Im only seeing 1 product per page.

  5. pennisol
    Posted 1 year ago #

    my themes had settings for max post, pages, etc per view (pagination)

    check all settings in your theme's backend. if not might be something hardcoded

  6. SummerN
    Posted 1 year ago #

    Thank You!!! Wow that was so simple!

  7. burdnick
    Posted 1 year ago #

    My theme doesn't have a backend option... i can't find it in the code for the display products per page.

  8. burdnick
    Posted 1 year ago #

    These products will also not display 3 wide, i can't modify it...

    the code calling the content is as follows:

    [product_category category="wake-boards" per_page="12" columns="3" orderby="date" order="desc"]

  9. xul
    Posted 1 year ago #

    In your WP Admin area, go to Settings > Reading and make sure "Blog pages show at most" value is set to the number of products you want to display. This fixed my issue.

  10. littlebizonline
    Posted 1 year ago #

    I'm having the same problem as pennisol - page is showing 5 products per page (4 on the first line, and one underneath) before having to click to the next page.

    I have added the code to the function.php and I have also checked the Settings>Reading solution, and this is set to 20, so still seeking a fix if anyone has any other suggestions?

    The site I am editing uses Elegant Theme (Modest)

  11. anandan111
    Posted 11 months ago #

    thank you!! this worked for me. I am using Trim theme elegant theme. I went to the Trim Theme Options under appearance tab in dashboard and scrolled down to the "number of posts displayed on archive" and just change that number to how many products you want to display on your shop base page =D Voila!

  12. J
    Posted 9 months ago #

    pennisol you are a savior! sneaky elegant themes....

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.