WordPress.org

Ready to get started?Download WordPress

Forums

Media Library Assistant
[resolved] Product Category Filter in Woocommerce (5 posts)

  1. niallolaoghaire
    Member
    Posted 5 months ago #

    Hi
    Again thanks for the great plug-in & prompt support on a previous question.
    When using woocommerce, I go to Products -> Categories -> click on edit category (from list) -> Upload/Add Image, the nice filter of all the images by Product Category isn't there.
    Thanks once again, Niall

    http://wordpress.org/plugins/media-library-assistant/

  2. David Lingren
    Member
    Plugin Author

    Posted 5 months ago #

    Niall,

    Thanks for your positive comments and for this report. I will have another look at WooCommerce and this issue after I return home on February 10.

  3. David Lingren
    Member
    Plugin Author

    Posted 5 months ago #

    Niall,

    Thanks for your patience! I have set up a WooCommmerce test site and run some experiments, reproducing your issue.

    The "Upload/Add image" button on the Product Categories screen does not work in the same way the "Add Media" button on the "Edit Post/Page" screens does; it opens a different kind of Modal Window.

    As you observed, the taxonomy (Product Category) dropdown control is missing. You can also see that the "All Media Items" and "Show All Dates" controls are missing as well. That's true even if MLA is deactivated.

    The only toolbar control that does show up is the search box, and the MLA enhanced search box seems to be working.

    This kind of issue has come up before, most recently in:

    filter/search issue

    I am working on some Modal Window enhancements for my next version, and I will continue my efforts to make MLA work with other plugins such as WooCommerce. I will leave this topic unresolved and post an update when I have progress to report.

    By the way, I want to make sure you understand how the filtering works. The dropdown control will show terms from whatever taxonomy you specify as the "List Filter" in the Settings/Media Library Assistant General tab. You also must check the "Support" box for the taxonomy and go through the process of assign terms from the taxonomy to your images. Unless you have done all that, filtering on "Product Category" will not do what you expect. If you have any questions about the process, let me know.

    Thanks for your interest in the plugin, for this report and for your patience while I work on a resolution.

  4. niallolaoghaire
    Member
    Posted 5 months ago #

    Thanks Dave, I'll look forward to your solution

  5. David Lingren
    Member
    Plugin Author

    Posted 3 weeks ago #

    I have released MLA v1.90, which changes the way controls are added to the Media Manager Modal Window toolbar. In my testing, this resolves the issue you reported with WooCommerce.

    I am marking this topic resolved, but please update it if you are still having trouble after upgrading to the new version. Thanks for bringing this issue to my attention and for you patience while I resolved it.

Reply

You must log in to post.

About this Plugin

About this Topic