WordPress.org

Ready to get started?Download WordPress

Forums

Problems with WordPress SEO XML sitemap (15 posts)

  1. Michellebc
    Member
    Posted 3 years ago #

    Can anybody help me with the following problem:

    I am using WordPress SEO plugin and and submitting the xml sitemap to Google.
    For some reason the status shown is a red X.
    I have tried resubmitting but the result is always the same.
    I also made sure the file is actually there ...

    Thanks,
    Michelle

  2. Agante
    Member
    Posted 3 years ago #

    Getting the same here wit the following error : Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead.

  3. bt-chadski
    Member
    Posted 2 years ago #

    * disregard *

  4. Joost de Valk
    Member
    Posted 2 years ago #

    Please all leave a URL where you're having issues, I can't diagnose without info :)

  5. bt-chadski
    Member
    Posted 2 years ago #

    Resolved with altering W3TC

  6. Michellebc
    Member
    Posted 2 years ago #

    Hi Joost,

    Here are the two of the URLs I am having issues with:

    http://wordpressinsider.org ( This one gets a red X )
    http://canadianeftgathering.com ( This one gets a yellow triangle )

    Thanks,
    Michelle

  7. Agante
    Member
    Posted 2 years ago #

    Hi Joost

    http://www.potchtrade.co.za

    Thanks!

  8. seanskilling
    Member
    Posted 2 years ago #

    i have the same issue, but i added the four sub sitemaps separately to google:
    Sitemap Last Modified
    http://www.foambook.com/post-sitemap.xml 2011-09-01 17:17
    http://www.foambook.com/page-sitemap.xml 2011-07-10 19:46
    http://www.foambook.com/category-sitemap.xml 2011-09-01 17:17
    http://www.foambook.com/post_tag-sitemap.xml 2011-09-01 17:17

    and it sees them, kludgy but working, still doesn't see the master index though

  9. Gunnsdeals
    Member
    Posted 2 years ago #

    Same issue here with red X
    http://gunnsdeals.net

    I am back to using XML Sitemaps for now, but would rather use yours.

    Thanks for the help Joost,

  10. Agante
    Member
    Posted 2 years ago #

    Following seanskilling's post, I have literally not joy in additional sitemaps with Google. Bing, however is reading mine without any issues... how can this be?

    For ref.:

    /sitemap-post-2011-02.xml
    /sitemap.xml
    /sitemap_index.xml
    /sitemap.xml.gz

    I have another question though; my site goes without the "www", but Google forces you to continue your submission of sitemaps with the "www"... Does this have any tangible effect on the results (that we all experience here)?

    Lastly, it does not matter what sitemap plug-in I use, the results remain the same.

    Thanks to everyone chipping in. I'm sure we will get results!!

  11. Michellebc
    Member
    Posted 2 years ago #

    I have solved the red X issue by fixing bad data in one of the category's canonical link.
    Found the problem by drilling into the error message in Google Webmaster tools

    Thank you for your time,
    Michelle

  12. toormore
    Member
    Posted 2 years ago #

    Hi I am using wordpress SEO plugin and am having similiar problems. Even after resubmitting, I am getting "Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead."
    I am using the Aggregate Theme from elegantthemes.com
    The site is http://housedesignonline.com
    Something simple I am sure but I'd welcome and advice.
    Thanks

    Bernard

  13. Ramnadh
    Member
    Posted 2 years ago #

    If you are having any problem with WordPress SEO Sitemap use any other WordPress plugin for creating sitemap.

  14. usf
    Member
    Posted 2 years ago #

    Plugin is no working any more. It did not split the tag site map after 50,000 urls. SE did not accept heavy sitemap that is more than 50,000. So it is the main bug in this mode. If you website has high traffic than Yoast SEO is no working any more.

  15. colortrails
    Member
    Posted 2 years ago #

    I am having problems with this aspect of the plugin as well. When I go to look at the newly created files within the plugin, it seems the files are there, but within CODA I cannot find the files where they are supposed to be i.e. not in my root directory anywhere). Are they hidden to editors?

    Also would love to see the option of applying a RANK to each file in the post editor, so we can do it as we go along. I am not 100% convinced that having every file show up the same default rank is a good idea. Why wouldn't Google or other engines use that information potentially? Unless there's a statement by each that says they specifically don't use it, I think we should have the option. :)

    Thanks for making such a great plugin!

Topic Closed

This topic has been closed to new replies.

About this Topic