WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Problems with Visual Editor in WP 3.1 (91 posts)

  1. kbarncat
    Member
    Posted 3 years ago #

    Well, well. I decided to do an entire fresh manual installation while I was trying to figure everything else out. I did it on my laptop. Evidently, the newest download I'd done on that machine (since there's no indication which version on the downloaded folder) was the one just before 3.1 -

    So I just simply went back in time, and now I've got my visual editor back, and i'm very happy. Never solved the problem with 3.1, but everything works now - and I'm not sure I'm really missing anything else that I had with 3.1.

    Hope I'm not stuck here forever. But my functionality is back. And that's what I need right now. I hope they fix it, whatever it is.

  2. byro
    Member
    Posted 3 years ago #

    Hi,

    I had exactly the same problem. Upgraded my WP install to 3.1 and the WYSIWYG editor buttons and text were disappeared.

    After checking all what I could I solved installing the FCKEditor plugin. It actually overrides the default editor and it is a bit more complete as well...

    Here there is the link to download it:

    http://wordpress.org/extend/plugins/fckeditor-for-wordpress-plugin/

    It seems to work for me even though it says to be compatible up to the version 2.8.5.

  3. byro
    Member
    Posted 3 years ago #

    Ok, having other problems with code snippets and FCKEditor I reverted to wordpress version 3.0.2 while waiting for a solution.

  4. Johansensen
    Member
    Posted 3 years ago #

    Thanks for the FCKEditor suggestion, this works for me too. Hardly a real solution, but it'll hold the users over until I can implement a functional alternative in Drupal and deploy that instead.

    Bye WordPress. I would say it's been fun, but honestly it really hasn't...

  5. kbarncat
    Member
    Posted 3 years ago #

    I was excited about the FCKEditor, dang it. As you see, I also reverted. When this happened in the first place, I searched the forums and came up with about six different threads, all addressing the same problem, but with different people suggesting different fixes on all of them. So I had to ride all the threads, hoping to find something that would work. I didn't. Tried everything. Nothing helped on any of my sites or browsers. All I got was a humiliating and unkind slap in the face for posting in too many places. It's not enough to send me to blogger. I like running my own show. But it's discouraging. I hope this isn't a multi-site thread, or I'll get slapped again. I don't know how to tell.

    I'm with Johansensen - this has not been fun in any way.

  6. garychild1953
    Member
    Posted 3 years ago #

    I added

    define('CONCATENATE_SCRIPTS', false );

    before the mySQL setting in wp-config.php and it worked.....
    +++++++++++++++++++++++++++++++++++++++++
    .....
    * @package WordPress
    */
    define('CONCATENATE_SCRIPTS', false );

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'xxx_xxx');

    ...etc
    +++++++++++++++++++++++++++++++++++++++++++++

  7. kbarncat
    Member
    Posted 3 years ago #

    Reading through all suggestions again. I really appreciated zoonini; very kind and patient with frustrated people who are really trying. I wonder if Laura ever solved it. I didn't.

  8. SteveEisner
    Member
    Posted 3 years ago #

    This appeared when we upgraded to 3.1 as well - garychild1953's fix worked for me:
    define('CONCATENATE_SCRIPTS', false );

    (I don't know if this is a core issue or a conflict with a common plugin, as we can't try it with all plugins disabled...)

  9. webular
    Member
    Posted 3 years ago #

    Ok. I figured it out(at least for me). Like many of you I wasn't seeing the Visual Editor option. I actually wasn't seeing either the "Visual" or "HTML" options in the add new post textarea.

    I went into my profile by going to: Users -> Your Profile

    There is where I noticed a new option which says: "Visual Editor" - with a checkbox that says "Disable the visual editor when writing". Mine was unchecked. So I thought all was ok. But what I had to do is:

    1) Check "Disable the visual editor when writing"
    2) Click "Update Profile" - this saves the setting and your visual editor is disabled.
    3) Uncheck "Disable the visual editor when writing"
    4) Click "Update Profile" - this saves the setting and your visual editor is enabled again.
    5) Voila - problem fixed. When I go to Posts -> Add new posts, the two options of "Visual" and "HTML" are back

    I was surprised that this worked, but hey after banging my head against this for a couple days I'll take whatever works.

    Good luck all!

  10. SimOliver
    Member
    Posted 3 years ago #

    @webular

    I so wanted this fix to work but sadly it did not for me.

    Interestingly as two of the original posters mentioned on this thread I am also on 123-reg (based in the UK) and the issue for me only seems to lie with them on my WordPress installation with this server.

    I have upgraded to 3.1 without any issues on two other sites where my hosting package has been with Bluehost.

    Their help desk says it is a WordPress bug and were not prepared to be of much more help.

    I have tried all the fixes suggested above on a completely empty site (no plugins, content and using twenty ten theme) and still no joy.

    The FCKEditor plugin has been the only thing that seems to work for me.

    Although it seems an excellent alternative it really bugs me that a universal solution hasn't been found.

  11. PaperVictory
    Member
    Posted 3 years ago #

    Gary's solution seems to have worked for me as well. I'm super grateful, because I didn't want to spend Saturday with this!

  12. 70relay
    Member
    Posted 3 years ago #

    Short version of the solution for that worked for us: deactivated the ShrimpTest Plugin and all was fine.

    Long version: we were having the same problem as described by very first poster.

    Setup:
    1. Using WP 3.1 on XP computer (me) and on Windows7 (wife)
    2. In IE8 the Visual Editor worked fine.
    3. Firefox and Chrome the Visual Editor showed no buttons and text was white.

    PHP was already 5.2 and changed to 5.3 (per user controls at host site). Nothing. Also tried a php change to the .htacces file that someone mentioned, but that hosed a bunch of stuff so I undid that. Reinstalled WP. Nothing worked.

    Finally did the tedious drill of checking the plugins (wife has 30 of them). Per Murphy's Law, the last plugin I reactivated broke FFx and Chrome, but at least I found the cause.

    Good luck,

  13. Correen
    Member
    Posted 3 years ago #

    @esmi Disabling plugins and adding back in one by one fixed the visual editor issue...I found the culprit. Thanks for your help...I thought there for a bit I was going to pull my hair out...{smiling now}!!

  14. MadGrin
    Member
    Posted 3 years ago #

    Hi,

    I had exactly the same problem. Upgraded my WP install to 3.1 and the WYSIWYG editor buttons and text were disappeared.

    I deactivated all the plugins and I discovered some of them (not in the incompatible list) that cause this problem.

    One of them is Subscribe2 http://subscribe2.wordpress.com/ that is compatible with my version of wp but cause the WYSIWYG editor buttons to disappear.

    I tried several of the fixes suggested in this thread but none of them allow me to use the Subscribe2 plugin.

    Any help?

  15. higltypig
    Member
    Posted 3 years ago #

    I'm also with 123-reg and also have no visual editor. I also installed using their handy app thingy.

    Darn annoying. I hope this gets fixed :(

    Kind regards

    Dave Rich

  16. tom coady
    Member
    Posted 3 years ago #

    OK here is fix for 123-reg:

    Rename
    /wp-includes/js/tinymce/themes/advanced/langs/wp-langs-en.js
    /wp-includes/js/tinymce/themes/advanced/langs/en.js

    You may also need to copy the containing folder, depending on the error messages in your browser inspector.

  17. higltypig
    Member
    Posted 3 years ago #

    hmm, i don't have a langs folder :(

  18. tom coady
    Member
    Posted 3 years ago #

    That's what I meant, just create one in the path where it's missing.

  19. higltypig
    Member
    Posted 3 years ago #

    cool, and where can i get a copy of the en.js file?

  20. higltypig
    Member
    Posted 3 years ago #

    nope, didn't fix my problem (found the file further up the file tress)

  21. tom coady
    Member
    Posted 3 years ago #

    Just rename or duplicate and rename wp-langs-en.js to en.js

  22. themightyant
    Member
    Posted 3 years ago #

    Hi another 123reg customer here I have a possible solution that worked for me.

    Go into Your settings -> General section of your admin.
    In Site URL or Home URL is there a colon ':' ?

    I had one added by 123reg, removing the colon bought back the visual editor.

    For those more advanced users you can check this also through phpMyAdmin. in the wp_options table look fro siteurl

    I hope it works for you too

  23. higltypig
    Member
    Posted 3 years ago #

    Hi another 123reg customer here I have a possible solution that worked for me.

    Go into Your settings -> General section of your admin.
    In Site URL or Home URL is there a colon ':' ?

    I had one added by 123reg, removing the colon bought back the visual editor.

    For those more advanced users you can check this also through phpMyAdmin. in the wp_options table look fro siteurl

    I hope it works for you too

    YEEESSSS!!!!!

    FINALLY!!!!!!

    wonderful,- thankyou thankyou thankyou!

    :)

    Made me friggin day that has :)

    Kind regards

    Dave Rich

  24. themightyant
    Member
    Posted 3 years ago #

    My pleasure higltypig, it's nice to be able to give back after getting help here in the past.

  25. The Web Post
    Member
    Posted 2 years ago #

    I had similar problems to everyone here, I wasn't getting most of the options in my editor and I had tried every other editor-plugin out there EXCEPT FCKEditor.(which worked)
    I tried EVERYTHING in this thread, NOTHING worked until I got to this post,

    After checking all what I could I solved installing the FCKEditor plugin. It actually overrides the default editor and it is a bit more complete as well...

    Here there is the link to download it:

    http://wordpress.org/extend/plugins/fckeditor-for-wordpress-plugin/

    I am running,
    The latest PHP 5.2
    The Latest FireFox 6.2

    Thank You, Thank You, Thank You, I now how everything I need and then some for options in my editor.

    http://thewebpost.net/
    CloneD

  26. duckonwater
    Member
    Posted 2 years ago #

    Hi another 123reg customer here I have a possible solution that worked for me.

    Go into Your settings -> General section of your admin.
    In Site URL or Home URL is there a colon ':' ?

    I had one added by 123reg, removing the colon bought back the visual editor.

    For those more advanced users you can check this also through phpMyAdmin. in the wp_options table look fro siteurl

    I hope it works for you too

    Thank you themightyant!

    We have a website hosted with 123 Reg and had same probs with visual editor. Your fix worked a treat.

  27. diana8760
    Member
    Posted 2 years ago #

    garychild1953 -- Many, many, many thanks. After spending many hours on this problem your fix worked like a charm! This problem occurred for me in version 3.2.1, only on Firefox. I am now confident that I can upgrade some other blogs without this becoming a major issue. Did I say thank you?

  28. phflupp
    Member
    Posted 2 years ago #

    Similar problems... not resolved by de-activating plugins or changing to 2010 theme.

    Also notice "Screen Options" and "Help" buttons are not working at all.

    Currently on version 3.2.1

    No other changes on the site so these problems were imported with the latest updates and so it seems WP needs to provide a comprehensive fix. The product is designed as a point and click interface so my feeling is that editing config files is a temporary workaround suitable for expert admins only.

    Please update the status of WP's work on these problems; ie, is anyone really working on them?

    Thx!

  29. esmi
    Forum Moderator
    Posted 2 years ago #

    There are no outstanding issues in WordPress 3.1 but you should be running 3.2.1 by now.,

  30. phflupp
    Member
    Posted 2 years ago #

    Yes I am... so you're recommending a rollback to 3.1? Ouch!

Topic Closed

This topic has been closed to new replies.

About this Topic