WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Problems with "umlaute" in the image filename (5 posts)

  1. film3macher
    Member
    Posted 2 years ago #

    Hi Alex Rabe,

    first I wanna thank you for your brilliant wordpress gallery. But I have a little problem with it. If the image has an umlaut in the filename, the gallery change it into weird characters so the image won't show in the gallery. I wrote a small funtion what changes umlaute into "normal" characters, but I don't know where I should but it in. Can you or anyone help me?

  2. You should never have accented characters or special characters of any kind (i.e. ampersands or asterisks) in any filenames of images or other files uploaded to the web. This isn't specific to any plug-in but a web-wide recommendation.

    To be safe, only use letters, numbers, hyphens, underscores or periods in file names.

  3. film3macher
    Member
    Posted 2 years ago #

    I know, I know. But I'm programming this page for an friend and he has over 400 pictures with a lot of umlaute in the filenames. So I thought I'm going to make it easier for him and pimp up the plugin. I just need to know where exactly I have to put in my mini tiny function. That's all. If I'm going to name a page in WordPress with an umlaut in it, wordpress changes it automatically. And I think this would be cool for the plugin too. Humans are stupid, they make mistakes, so we have to make our programming better instead of telling everyone what they allowed to do and what not.

  4. I see! I hope someone can help. :-)

  5. lombrano
    Member
    Posted 2 years ago #

    Hello, I've got the same problem. Did you find a solution ?
    Thanks a lot

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.