WordPress.org

Ready to get started?Download WordPress

Forums

Codestyling Localization
[resolved] Problems with translation when using poedit (14 posts)

  1. PILOTUSA123
    Member
    Posted 1 year ago #

    Hello there,
    I have translated a theme using poedit. Some of the lines was marked as fuzzy translation. And unchecked the fuzzy`s lines and saved. Uploaded the po file into the lang folder via fpt, but when I re-scan and generate the mo file, it show that 220 lines are not translated.
    Can you please help me?

    Thanks
    Ps: I got the file if you need to look at it..

    http://wordpress.org/extend/plugins/codestyling-localization/

  2. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    Depends on what have been changed at php source files in relation to existing po file. If you rescan, than it will check, if the source string is contained at current translations within po file. If so, it will be kept, if not, it will place it as new one string.

    Example:
    PHP code contains "Car"
    PO File contains "car" => "Auto"
    rescan can't find "Car" and places it as untranslated into the rescanned PO file.

  3. PILOTUSA123
    Member
    Posted 1 year ago #

    What happened is the following: I bought themes from woothemes, them I generated the pt_BR.po sent to my translator in Brazil. She is using the poedit program to translate it. When I got them back, I noticed that 220 lines had fuzzy translation, so I manually unchecked them all.
    Saved the file->Uploaded via ftp-> rescanned using codestyling and generated the mo file, and that is when the problem begin.
    What should I do in order to fix this?

    Thanks
    Davys

  4. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    This sounds crasy. Did the translation file *.po also loose the texts or are they only not shown at page?
    The main problem to analyse what went wrong is, that i haven't the affected theme and also not you base tranlation files. If I would have them within my local test environment, I could analyse and fix the bug, if any contained (either my plugin or elsewhere).
    If you think, it worth going this way, please send me the theme and translation by mail (can be found at my imprint page).

  5. PILOTUSA123
    Member
    Posted 1 year ago #

    Thanks for your reply.
    I just sent you an email with the theme and the pt_BR.po that I got from the translator.
    I left inteact so you can see how the file looks like when you open it with poedit.
    Please notice that most of the lines got fuzzy checked if you open it with poedit.
    I did unchecked the fuzzy translation lines to see if it would work, but it did not.
    Let me know what you discover.

    Thanks again
    Davys

  6. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    The translation you have is for version 1.2.1 of the theme but you have version 1.3 of theme. The author did change quite a lot of texts, so your previous translation doesn't match the new theme 100%. Texts not longer matching are threat as none translated and this leads to "loosing" approx 200 translation strings.
    The only way to handle this is to compare the old *.po file with a fresh scanned one and adjust the msgid strings appropriated. Afterwards the translation can be adjusted using my plugin as required.

  7. PILOTUSA123
    Member
    Posted 1 year ago #

    Thanks so much for everything.
    You are very good at supporting this plugin,and I really appreciate that.
    I am understood everything you are talking about. But unfortunately I am still having a slightly different problem.
    I wanted to try another theme to make sure that was the problem.
    Here is what I did. I updated the theme wootique, went back to your plugin, clicked on scan, and opened the list of translations. At this time every single line was translated, but translations still not showing..So I don`t know if it is a WP 3.5 bug or theme.
    Maybe you can shine a light on my problem?

    Thanks
    Davys

  8. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    I have tested the free download version of Wootique. It was not provided with languages except en_GB. So I did create a new one in german "de_DE", did translate the 3 "Response" texts used to show the commenter count at a blog article and generated the mo-file.
    Afterwards the blog article correctly shows this translation.
    Within my wp-config.php the WPLANG is set to "de_DE", may be your config is not set to your language?

  9. PILOTUSA123
    Member
    Posted 1 year ago #

    Mine is set to pt_BR. The wooframework at the backend is where tanslations does not show.
    I opened a support ticket with woothemes.
    Waiting to hear from them.
    If you want to try in Portugue Brazil, I have the mo po files if you want to check it out.
    I don`t think is your plugin. I thing is a bug with woothmes framework.
    It started after I updated to wp 3.5

    I am running multisites. I don`t know if that is relevant or not.

    Thanks

  10. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    Would be great if you could provide the translation files by mail . I will check it this evening with my local multisite environment.

  11. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    Clarified, Woothemes as known for backends, that are not translatable but hard coded english.

  12. PILOTUSA123
    Member
    Posted 1 year ago #

    Thanks so much for looking into it for me.
    It is ashame that they are somewhat unorganized when it comes down to the wooframework.
    I expressed my disatisfaction, but I don`t think that will change anytime soon...

    Thanks
    Davys

  13. franckbinisti
    Member
    Posted 7 months ago #

    Hi,

    I uplaod my po and mo files and i upload them by filezilla. But my upload doesn't work on my website.

    Everything is working on filezilla and with my wp-config everything ik ok (define('WPLANG', 'fr_FR');)

    I use bazar child. But in the fils languages there is no language. I think it's normal and we should see with his parent fil : Bazar.

    On Bazar => Language, i replaced my old po and mo files by my upload files. But there is no upload on my website like you can see on http://www.padelachat.com (up and right to the home page with cart, wishlist, etc.)

    PLEASE HELP ME BECAUSE I LOST MANY DAYS ABOUT THAT.

    Thanks

  14. Christopher Anderton
    Member
    Posted 7 months ago #

    franckbinisti -> Cheers. I think you need to start a separate thread as your problem is a different one. Be sure to read all documentation and look at in the forum for solutions (if any).
    http://wordpress.org/support/plugin/codestyling-localization

    Also check out the French WordPress forum.
    http://www.wordpress-fr.net/support/index.html

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.