WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem with Thickbox enabled (16 posts)

  1. lood
    Member
    Posted 4 years ago #

    Howdy howdy howdy,

    I've just switched to using your theme, and I love it. I noticed a problem and tracked it down to some problem with having the Thickbox theme enabled, though. The comments/trackback tabs don't work, and I get the following error:

    $("tabs").tabs is not a function

    I've got a basic familiarity with what I'm doing but I was wondering if there's an easy way to simply remove the tabs and have comments & trackbacks combined as it sounds like you once had. That, or if you have any idea what might fix that error, even better.

    Thank you so much for a great theme!

  2. andreiluca
    Member
    Posted 4 years ago #

    Please link your website and I'll check it ASAP.
    Thanks.

  3. lood
    Member
    Posted 4 years ago #

    Holy crap, you're fast!

    http://awesomelymodest.com/blog

    If you need me to try disabling or modifying something for you to see where the problem is, let me know. Not the most pressing issue because up until recently I've had comments disabled entirely, but I'm considering starting to use it more frequently- hence the reason I found your theme.

    Thanks again!

  4. andreiluca
    Member
    Posted 4 years ago #

    Hello,

    We (lightword/thickbox) use different versions of jQuery (javascript framework) so I can't find any elegant solution for this.

    Anyway.. try to replace these two files.
    http://www.box.net/shared/te2bpf8a68

  5. myfightbrand
    Member
    Posted 4 years ago #

    Hi Andrei,

    I am using your theme and I would like the Categories Displayed on top rather than the pages.

    The lightword settings do not let me save that feature however the reset button works.

    Also, your paypal link does not work.

    Please help, thanks

  6. myfightbrand
    Member
    Posted 4 years ago #

    Also,

    The pre Home link associated {pages widget} has become its own link and not relative to the site as it repeats information and does not update along with the rest of the site.

    I had to reinstall WordPress trying to debug why the link does not update.

    Thanks

  7. andreiluca
    Member
    Posted 4 years ago #

    Hi,

    - categories on top | works on my end so please give me more details
    - paypal button | thanks, fixed
    - home link | sorry. I don't understand, any url please?

    Thanks.

  8. myfightbrand
    Member
    Posted 4 years ago #

    http://www.myfightbrand.com

    - When I check the categories on top option and try to save...the save button is non functional. It does not save/update when I check the option.

    - The home page links back to home page but does not reflect any updates I make to a 'home page' that I created. Then I end up with 2 'home' pages...it puts a tab for 'home' right next to the one that comes with the theme. ?? Any thoughts? ---Maybe it will change once I have Categories on top rather than pages on top. That is what I prefer anyway.

    Love the layout by the way.

  9. andreiluca
    Member
    Posted 4 years ago #

    - only that option? others work?
    - the home button is 'fixed', you can delete it from header.php (line 27) if you want.

  10. myfightbrand
    Member
    Posted 4 years ago #

    no, the others do not.

    I would like the categories in the header buttons. so cool.

    But to answer your question, no the other checkboxes to not save when pressing the save button. Should I re-install the theme?

  11. andreiluca
    Member
    Posted 4 years ago #

    hm.. what browser are you using?

  12. myfightbrand
    Member
    Posted 4 years ago #

    IE7?

  13. andreiluca
    Member
    Posted 4 years ago #

    Try this version and tell me if it's ok.
    Also, what WP are you using?

    http://www.box.net/shared/he3oixey7o

  14. myfightbrand
    Member
    Posted 4 years ago #

    SWEET!! Thanks!

    Currently using 2.8

    Any help with placing Ad banners?

  15. lood
    Member
    Posted 4 years ago #

    Howdy howdy howdy,

    Thanks for your quick response. Unfortunately replacing the header & footer files didn't do the trick.

    You've pointed out that your theme and thickbox are using conflicting versions of jquery, which has had me searching around for solutions. While I've seen an alleged fix to get thickbox working with v1.3.2 (remove the @ from line 79), doing that and disabling it's calling v1.2.3 is letting your tabs work but thickbox hangs.

    The only way to resolve this may be dealing with the broken tabs until I find a replacement for thickbox (or the author updates it)

    I appreciate your assistance!

  16. lood
    Member
    Posted 4 years ago #

    Update: I've managed to get something working.

    It clicked with me that WP 2.8 is using thickbox constantly for themes, plugins, etc. I checked to see which version of jquery it was using, and lo and behold, it's using v1.3.2!

    The thickbox plugin has two thickbox js files. I was editing line 79 of thickbox.de.js file, as thickbox.js looked like some super obfusicated code (seen here)

    I noticed when I switched from using Default to de, both thickbox and the tabs worked! Except, thickbox was now in Deutch! That explains the 'de'.

    So I copied the thickbox.js to the above linked file, then copied normal-looking thickbox.js from wp-includes/js/thickbox/ and made minor modifications for the loading/closing images, and it works!

Topic Closed

This topic has been closed to new replies.

About this Topic