WordPress.org

Ready to get started?Download WordPress

Forums

Problems with themes/theme editor (5 posts)

  1. picaman
    Member
    Posted 7 years ago #

    Yesterday I updated to 2.1.3 from 2.0.9. Now in the Presentation > Themes tab, none of my themes (including the default themes) show previews. In addition, in the Theme Editor, I get an error message saying "Oops, no such file exists" for every theme.

    The themes I use have an options tab, which tells me that "the theme is currently not activated on your site as the default theme", even though it's the currently selected theme.

    I've set my permissions as per this page:

    http://codex.wordpress.org/Changing_File_Permissions

    and have set /wp-content/themes/ to be group writable. I've also tried disabling all my plugins. Nothing so far has worked.

    I'd like for my Themes tab to function properly, and for WP to recognize my chosen theme as the default theme. I can live without editing the theme within WP, but the rest should function properly.

    Any ideas? Thanks in advance for any help.

    Jamie

  2. jbbrwcky
    Member
    Posted 7 years ago #

    Are you using the theme switcher plugin?

  3. picaman
    Member
    Posted 7 years ago #

    Not using it, and it's not even installed and deactivated. Thanks for the idea, though : )

  4. picaman
    Member
    Posted 7 years ago #

    I checked the source for the page, and here's how WP is outputting the link for the preview:

    <img src="http://www.sitename.com///screenshot.png" alt="" />

    It's not populating the folder names, which should be, for example:

    <img src="http://www.sitename.com/wp-content/themes/barthelme/screenshot.png" alt="" />

    Any ideas?

  5. picaman
    Member
    Posted 7 years ago #

    Bump for this question. Any ideas why WP would not generate proper page code for my themes page in wp-admin? See above.

    Thanks in advance.

Topic Closed

This topic has been closed to new replies.

About this Topic