WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problems with sidebar.php (16 posts)

  1. windstyles
    Member
    Posted 3 years ago #

    I am having issues with my sidebar.php file. It works perfect in Firefox, but is a mess on IE8. If I fix it to work on IE8, it isn't right on Firefox. Is it possible to make two sidebars and call one for IE browsers and another for all others (like you can with stylesheets) ?

    Here is the file. Again, works great in Firefox, but not working right in IE8. The Pages work great, but then it gets to Categories and it changes the type of LI. If I fix it in IE8, it doesn't work in Firefox.

    http://wordpress.pastebin.com/sB9A1srK

    Appreciate anyone's help! :)
    Thank you!

  2. windstyles
    Member
    Posted 3 years ago #

    Bump :)

  3. davidandre
    Member
    Posted 3 years ago #

    Hi,
    yes it is possible but i thing it is an css issue. check your css file first.

  4. windstyles
    Member
    Posted 3 years ago #

    Thank you, davidandre.

    Here is a link to my CSS file:

    http://wordpress.pastebin.com/Md30JRGY

    Any thoughts on how to make it work in IE? Thank you!

  5. davidandre
    Member
    Posted 3 years ago #

    tell us what is the url of your site then sure someboby find a way to help you

  6. davidandre
    Member
    Posted 3 years ago #

    I really dont know without seeing your site but try to put a clear left at:
    #sidebar-bot{
    background:#a3c54c url(images/sidebar_bott.gif) no-repeat;
    width:196px;
    height:32px;
    clear:left;

    }

  7. windstyles
    Member
    Posted 3 years ago #

    Added the clear left and that didn't work.

    The site is http://cincinnati-green-plumbers.com/

    Thank you so much for your help, it's truly appreciated! :)

  8. davidandre
    Member
    Posted 3 years ago #

    I dont have much time right now but i looked quickly in your sidebar.php as i ve seen bade code in your css.file and i guess you have very confusing
    ul and li tags...
    You have:

  9. <h2>Categories</h2>

      <?php wp_list_categories('exclude=2&title_li='); ?>
  10. Try something simple like:
    <h2>categoris</h2>

      <?php wp_list_categories('exclude=2&title_li='); ?>

    then you might have to put a #sidebar h2 {margin-left:10 or more px;}

    try this and let me know

  • davidandre
    Member
    Posted 3 years ago #

    sorry the code doesn t show off

  • davidandre
    Member
    Posted 3 years ago #

    h2 entradas por temas h2
    ul
    <?php wp_list_categories('show_count=1&title_li='); ?>
    ul

    try like this! with the <> </> of course

  • davidandre
    Member
    Posted 3 years ago #

    <h2>categories</h2>

      <?php wp_list_categories('exclude=2&title_li='); ?>
  • windstyles
    Member
    Posted 3 years ago #

    Davidandre, I really do appreciate your help, but I already have the code as you list above with the ul and /ul before the wp_list_categories

    This is not my template, so I cannot speak as to why the code may/may not be wrong.

    Any ideas on how to add a second sidebar.php that only works in IE, if possible?

    Thank you!

  • davidandre
    Member
    Posted 3 years ago #

    Hi,
    no you dont have the same code.I didn t explain myself well...
    so eliminate the li on the lines 22,27,34,41 and we ll see what happens.
    i am pretty sure this a problem of li , look at "pages" it displays well on every browsers...

  • davidandre
    Member
    Posted 3 years ago #

    Hi,
    no you dont have the same code.I didn t explain myself well...
    so eliminate the li on the lines 22,27,34,41 and we ll see what happens.
    i am pretty sure this a problem of li , look at "pages" it displays well on every browsers...

  • windstyles
    Member
    Posted 3 years ago #

    Thank you, David. That didn't work exactly, but you got me on the right track!! I went in and removed the overall ul tags and enclosed each section in their own ul /ul and li /li tags and it works now in both browsers!!

    Thank you so much for all of your time and help this morning. If it weren't for you, I would've pulled all of my hair out. :)

    Have a great day

  • davidandre
    Member
    Posted 3 years ago #

    No worries,
    glad it is working well now.
    bye

  • Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags