WordPress.org

Ready to get started?Download WordPress

Forums

Problems with sidebar, help? (7 posts)

  1. BrunoDavid
    Member
    Posted 7 years ago #

    Hi everyone

    I'm having 2 little problems with my sidebar:

    1- When viewing my website (www.fingerboardpt.com) the GPS globe icon on the top of the sidebar gets overlayed by the 'Menu' layer when using Firefox. However, using IE7 everything is fine, just as i want. I use a line break between the image and the 'Menu' layer. Many people use firefox so can you help me? :(

    2- Second, when using images in the sidebar they get automatically aligned to the left and that leads to problems like this: http://img145.imageshack.us/img145/8650/shoutboxog8.jpg in my shoutbox.

    Thanks

  2. Alex Cragg
    Member
    Posted 7 years ago #

    1 - if you assign the globe a unique id, then copy the css for your .topgrad img, but change its position to relative, not absolute. you need the unique id so that other images with .topgrad img aren't affected. 2 - cant diagnose cause there arent any there at the moment, but im sure it'll be a css issue again.

  3. BrunoDavid
    Member
    Posted 7 years ago #

    hmm i guess i'm not understanding very well what you're saying :| This is the piece of code that controls the globe:

    <div align="center" id="gps"><a href="http://fingerboardpt.com/?page_id=45"><img src="http://fingerboardpt.com/images/GPS.gif" width="50" height="50" border="0" /></a><br>

    It is placed right after the
    <ul> that controls the text over/links over it ("Favoritos","RSS Feed"). I tried to add:

    <ul></ul>

    after the globe code to generate a space but that didn't help in firefox. It's weird because in IE7 it is just perfect.

    Thanks

  4. Alex Cragg
    Member
    Posted 7 years ago #

    ok, i see it now, but there are no style rules associated with gps. so it is using .topgrad img.

    Ive come up with one solution you could use though.

    find .topgrad img in your css and delete position:absolute;

    you also have .topgrad with position:relative; so this takes over. and other images in your posts are not affected.

    the other option is to create a style for #gps, and have its position as relative, not absolute.

  5. BrunoDavid
    Member
    Posted 7 years ago #

    First, thanks for trying to help me! Unfortunatly there's no .topgrad reference in the style.css of my theme. I tried to remove the position:absolute; from a reference named .favorite .fav , .favorite .rss in the css file but nothing happened.

    Anyway, i tried to add &nbsp; after the globe code. As you can see from my page, now the globe is a bit "heigher" and you almost can see all of it in firefox. The funny thing is that using IE7 the globe is in the exact same position as using the line break<br> :|

    This problem is driving me nuts...

    Greetz

    EDIT: Well, i just added another &nbsp; and now i can see the whole globe in firefox. However, there's in an extra space when viewing in IE7. Basically, two line spaces in firefox = one line space in IE7. Maybe this is some screen resolution problem...

  6. Alex Cragg
    Member
    Posted 7 years ago #

    .topgrad is listed in your header, its hard coded in, as opposed to in your css file

    <link rel="stylesheet" href="http://fingerboardpt.com/wp-content/themes/soccer-10/style.css" type="text/css" media="screen" />
    <link rel="alternate" type="application/rss+xml" title="FingerboardPT.com - Portal Nacional de Fingerboard RSS Feed" href="http://fingerboardpt.com/?feed=rss2" />
    <link rel="pingback" href="http://fingerboardpt.com/xmlrpc.php" />
    
    <style type="text/css" media="screen">
    * html .topgrad img {left:-568px;}
    .botgrad { background: url("http://fingerboardpt.com/wp-content/themes/soccer-10/images/pagebg.jpg") repeat-y top; border: none;z-index: 1;position:relative;}
    .topgrad img {left:0px;top:0px;position:absolute;z-index:0}
    .topgrad * {position:relative;}
    </style>
    
    	<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://fingerboardpt.com/xmlrpc.php?rsd" />
  7. BrunoDavid
    Member
    Posted 7 years ago #

    Oh i see, that seems to work in the sidebar but the central block (where the news and new articles go) gets misaligned (dunno if this is the right word), the text goes down like 2 paragraphs even without no paragraph code in the sidebar.

    Thanks for the help anyway, i think i'll let it as it is :)

Topic Closed

This topic has been closed to new replies.

About this Topic