WordPress.org

Ready to get started?Download WordPress

Forums

Problems with Permalinks and .htaccess (3 posts)

  1. Amity
    Member
    Posted 8 years ago #

    I have read some of the threads in this forum regarding 500 Internal Server Errors when Permalinks are activated in WP. I experienced the same problems, so I took it to my host's support dept. Here is the response that I received:

    "We are running php as cgi module on server. This is to ensure the server
    security against hacks and sql injections implemented thru php scripting.

    Hence the rewrite rule specified in .htaccess wont work."

    Is there another way around this? I guess I could manually create a page, so I'll have to learn a few things...

    Mike

  2. Cypher
    Member
    Posted 8 years ago #

    My host also runs PHP as a CGI module and this has NOTHING to do with permalinks.

    Your host is, how do I put this nicely, dumb. :)

    You need have mod_rewrite enabled in Apache and then your rewrite rules will work.

    This is a Apache/Htaccess issue and has nothing (shockingly) to do with PHP.

    Regards

  3. Amity
    Member
    Posted 8 years ago #

    I contacted my host again, and mod-rewrite is enabled.

    I'm lost. The archive page isn't totally vital, but it is a nice feature for a photoblog.

    Should I include some of the text from my .htaccess file in this support forum?

    Mike

Topic Closed

This topic has been closed to new replies.

About this Topic