WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Problems with permalinks after upgrade (75 posts)

  1. NFWRo
    Member
    Posted 3 years ago #

    Hi
    I've just upgraded to the latest version of NextGen Gallery and now my galleries do not show. I'm getting a Page Not Found error. If I uncheck the Deactivate gallery page link in the Gallery settings, clicking on the links to the galleries simply refreshes the gallery page without showing the requested gallery. If I uncheck the Activate Permalinks option in the General Options, then the galleries show but without a title or anything.

    I have tried clicking the Save button to update the Permalinks, which I gather is the way to do this, but it has no effect and everything remains the same.

    Also, the styling of my gallery page seems to have been lost.

    Any help greatly appreciated.

  2. Alex Rabe
    Member
    Posted 3 years ago #

    Please post a link

  3. NFWRo
    Member
    Posted 3 years ago #

  4. Alex Rabe
    Member
    Posted 3 years ago #

    Your pages have the .html extension in the url, is this done by a rewrite rule or a plugin ?

  5. NFWRo
    Member
    Posted 3 years ago #

    That is done using the .html on PAGES plugin.

  6. Alex Rabe
    Member
    Posted 3 years ago #

    Maybe this causes a conflict, try to disable it for a test (and update the permalinks then) If this doesn't help you can downgrade for a test :

    http://wordpress.org/extend/plugins/nextgen-gallery/download/

  7. NFWRo
    Member
    Posted 3 years ago #

    It has been working fine with the previous version, so I know that downgrading should fix it.

    Disabling the .html on pages plugin does work, does that mean I can't run the two plugins at all together, because I use the .html on pages plugin to help with SEO.

    Having said that, if I set the gallery to display the thumbnails on the same page, that still refreshes back to the gallery page. The styling is also gone.

    Thanks for your help.

  8. Li-An
    Member
    Posted 3 years ago #

    Same problem here.
    See the album: http://www.li-an.fr/blog/galeries-dimages/
    Clicking on a gallery gives a 404 error and even a post !?!
    The link for the first gallery is "http://www.li-an.fr/blog/galeries-dimages/nggallery/illustrateurs" and should be "http://www.li-an.fr/blog/galeries-dimages/galerie-illustrateurs/"
    So there is a nggallery that should not be here !!

  9. Alex Rabe
    Member
    Posted 3 years ago #

    @Li-An the permalink structure changed as written in my blog post, did you resfresh your pemalinks ?

  10. NFWRo
    Member
    Posted 3 years ago #

    Also Alex, the Slideshow link is missing.

    I've fixed the styles - course I made changes to the .css file and they will have been overwritten, so that's no problem.

  11. Alex Rabe
    Member
    Posted 3 years ago #

    @NFWRo No idea so far, you should stay on the previous version until I get an feeling what it could be, maybe other user report the same sses

  12. NFWRo
    Member
    Posted 3 years ago #

    I've seen a few people saying that the slideshow link isn't working.

    Can I just reinstall the previous version. There was a database upgrade as well....

  13. Alex Rabe
    Member
    Posted 3 years ago #

    Yes you can downgrade

  14. Nekmak
    Member
    Posted 3 years ago #

    what is the process to downgrade to previous version? i am a newbie please help. I have several galleries and photos which i dont want to loose.

    Thanks

  15. Peter
    Member
    Posted 3 years ago #

    What is meant by updating permalink structure one time? Currently my permalink is “custom structure”: /%postname%/

    Is something else needed? When I checked "Activate Permalinks" with slug of nggallery and went to my permalinks and clicked save with the above mentioned permalink structure, No galleries would open. Album thumbs were shown but when I clicked on the thumb I just remained on the page that showed all the albums/galleries.

    thanks for you help.

    Peter

  16. Alex Rabe
    Member
    Posted 3 years ago #

    Please post a link

  17. Peter
    Member
    Posted 3 years ago #

    It's on my local server so I can't post a link.
    But here's how it looks: localhost/wordpress/picture-galleries/

    This shows all the galleries such as: localhost/wordpress/picture-galleries/?album=1&gallery=1 etc.

    When I have "Activate Permalinks" checked with slug "nggallery" the link is: localhost/wordpress/picture-galleries/nggallery/bugs/flys
    but it just reloads localhost/wordpress/picture-galleries/

    I think that's all I'm able to provide since it's on my localhost.

    Peter

  18. Alex Rabe
    Member
    Posted 3 years ago #

    Disable other plugins & also test version 1.7 of NGG

  19. Peter
    Member
    Posted 3 years ago #

    okay

  20. ip00
    Member
    Posted 3 years ago #

    I'm also having this same problem. Pagination doesn't work it just refreshes the first gallery page after clicking on second, third or else...

    At first, before updating permalinks, it showed 404 page but now it just reloads the first gallery page.

  21. forumcivico
    Member
    Posted 3 years ago #

    Just subscribing. We need to be sure permalinks work before upgrading. We do use .html in our permalinks, and cannot do otherwise per our publisher policy.

  22. Alex Rabe
    Member
    Posted 3 years ago #

    I need to know which other plugins you are using (exact names)

  23. Nekmak
    Member
    Posted 3 years ago #

    hey people,

    how can i owngrade to an older version of the nextgen gallery?i am also facing several issues, i had disable all other plugins but none of them seems to create a problem.

    Thanks

  24. ip00
    Member
    Posted 3 years ago #

    Plugin list:

    - Contact Form 7
    - Google Analytics for WordPress
    - Google XML Sitemaps
    - Jetpack by WordPress.com
    - Platinum SEO Pack
    - User Role Editor

  25. Alex Rabe
    Member
    Posted 3 years ago #

    Thanks, if you disable the permalinks in the gallery settings , does it work for you ? (Again please post always a link to you blog)

  26. Truth
    Member
    Posted 3 years ago #

    I've this problem as well, once I enabled the permalinks, the pagination doesn't work. Gallery slug name is: portfolio.

    Example: http://dayna.me/portfolio/illustrations/

    Click on page 2 (URL: http://dayna.me/portfolio/illustrations/page-2/ )
    and it goes back to http://dayna.me/portfolio/illustrations/

    I did update my permalinks after turning on this setting.

    Deactivate it again, the link to page 2 is http://dayna.me/portfolio/illustrations/?nggpage=2 and it's working.

    Bug?

  27. Alex Rabe
    Member
    Posted 3 years ago #

    @truth

    Do you change the slug to "portfolio" ? try the default slug "nggallery" and test again

  28. Truth
    Member
    Posted 3 years ago #

    @Alex

    Yes, I did. I changed it back to "nggallery", the URL becomes
    http://dayna.me/portfolio/illustrations/nggallery/page-2

    and clicking on the above brings me to
    http://dayna.me/portfolio/illustrations/

  29. Alex Rabe
    Member
    Posted 3 years ago #

    ok, then please install this plugin : http://wordpress.org/extend/plugins/monkeyman-rewrite-analyzer/

    Activate the gallery permalinks & look at Tools -> rewrite analyzer. Please post a screenshot of the page you see there.

    I feel my rewrite rules ( permalinks ) still not cover all custom permalink structures

  30. Truth
    Member
    Posted 3 years ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.