WordPress.org

Ready to get started?Download WordPress

Forums

Problems with permalinks (18 posts)

  1. launchpadmedia
    Member
    Posted 7 years ago #

    I have all of my WordPress files set up at: http://www.launchpadmedia.com/blog/

    I am trying to use the following format for permalinks:

    Date and name based
    http://www.launchpadmedia.com/blog/2007/07/22/sample-post/

    Example posts:
    http://www.launchpadmedia.com/blog/2007/07/22/test-permalink/
    http://www.launchpadmedia.com/blog/2007/07/22/permalink-test-3/

    However, I consistently receive the following errors:

    Not Found
    The requested URL /blog/2007/07/22/test-permalink/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I made sure to change the permissions on my .htaccess file to 666 when making my permalink selection. I did this via FTP, as I do not know how to work in a UNIX terminal.

    I even took the step of uploading a blank file to .htaccess to start over. This is the code that appears in my .htaccess file, written by WordPress when I selected the permalink format:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    # END WordPress

    I am wondering if WordPress is giving me the wrong path in that code or something.

    When I revert back to the default permalink format, everything works (post and comment links all work fine), but I do not wish to remain in that link format. I have been reading support and blog posts on this topic for over 3 hours trying to find a solution to this problem, but I just do not know what I am doing wrong. HELP!

    I am running WordPress 2.2.1, PHP 4.3.2, and MySQL 4.1.15.

    THANK YOU!

  2. whooami
    Member
    Posted 7 years ago #

    do you even know if your host support mod_rewrite?

  3. launchpadmedia
    Member
    Posted 7 years ago #

    @whooami

    I asked before I installed, and my hosting provider told me my account supported the mod_rewrite Apache module.

  4. Chris_K
    Member
    Posted 7 years ago #

    Lots of troubleshooting at the Permalinks page in the Codex.

    Does "supported" mean the same as mod_rewrite on and AllowOverrides enabled for your directory?

  5. launchpadmedia
    Member
    Posted 7 years ago #

    @ HandySolo

    Lots of troubleshooting at the Permalinks page in the Codex.

    I have been over and over this page, it was the first place I tried for help, but so far, I have not had any luck with any of the information there.

    Does "supported" mean the same as mod_rewrite on and AllowOverrides enabled for your directory?

    I will contact my hosting provider to check on this. Thanks.

  6. launchpadmedia
    Member
    Posted 7 years ago #

    @ HandySolo

    When I uploaded a blank .htaccess file to my server to undo any bad changes I may have made, WordPress was able to write to it with the code I included above. Wouldn't this indicate that my mod_rewrite abilities are working correctly?

  7. Chris_K
    Member
    Posted 7 years ago #

    That would "just" indicate that your web server now has write access to the .htaccess.

    Not really related to mod_rewrite (although if previous attempts to write to the .htaccess had failed, that would explain your original issue).

  8. launchpadmedia
    Member
    Posted 7 years ago #

    Does "supported" mean the same as mod_rewrite on and AllowOverrides enabled for your directory?

    My hosting provider is not getting back to me on this. They are very rigid about offering any kind of help with outside software, so I am not surprised. (Might be time to move my hosting...)

    Is there some way I can check into this myself? I am willing to try to learn UNIX commands, but I do not know where to start...

  9. moshu
    Member
    Posted 7 years ago #

  10. launchpadmedia
    Member
    Posted 7 years ago #

    @moshu

    Thanks for that info. It's very interesting to see all that data. Unfortunately, there is no mention at all of mod_rewrite and AllowOverrides (either enabled or disabled) in the results I see.

    This is really getting frustrating. It seems like if these permalinks are an option, I should just be able to select that option and they should display the right way, with WordPress making whatever necessary changes behind the scenes for me. I am not sure why this is getting so hard and requires so much backend stuff that I just don't understand enough to troubleshoot effectively.

    Is there a resource where I can find a programmer to pay to assist me in getting this working? It seems like this would just take a few minutes for someone who actually understands all this server stuff.

  11. moshu
    Member
    Posted 7 years ago #

    mod_rewrite should be listed among many, many other things in a section called "Loaded modules"

    WP does all the background work - IF that rewrite module is active on the server. If it is not... then you cannot use the nice permalinks. It's that simple.

  12. launchpadmedia
    Member
    Posted 7 years ago #

    @moshu

    Thanks for replying. I checked, and I am not even seeing a section called "Loaded Modules" on my phpinfo results page. There is a section called "Additional Modules," but that only lists sysvsem and sysvshm, nothing else.

    I will try to pester my hosting provider again... That seems like my only remaining option. All suggestions welcome!

  13. moshu
    Member
    Posted 7 years ago #

    Leave that file up for 5 more minutes and give the url for it. I'll delete it later from the post, just let me see it :)

  14. launchpadmedia
    Member
    Posted 7 years ago #

    @moshu

    [link moderated]

    Thanks for any other tips you can provide. :)

  15. moshu
    Member
    Posted 7 years ago #

    Unfortunately, I have no idea why it doesn't work. I checked on several sites and not all that have mod_rewrite enabled have it displayed in the phpinfo... Another mystery, time to learn about it :(

    Let's hope some more knowledgeable htaccess gurus will jump in!

  16. alexo05
    Member
    Posted 7 years ago #

    FWIW, I too have encountered this same problem.

    Here's the kick, while using WP 2.2, permalinks worked. Now that I just upgraded to 2.2.1, they do not.

    mysql 4.0, hosted by godaddy.

    This is what GoDaddy sez about mod_rewrite:

    Mod_rewrite is an Apache web server module installed on all of our Linux severs by default; it does not have to be installed or enabled. Our Linux hosting accounts support most mod_rewrite functionality.

    You will not need to enable mod_rewrite in your httpd.conf, as this is handled at a global level. All you will need to do is add the desired code to the body of your .htaccess file.

    NOTE:The .htaccess file containing the rewrite rules must be in the same directory as the target files.

    Hope it sheds some light into the problem.

  17. pmike4343
    Member
    Posted 6 years ago #

    On Godaddy or secureserver linux hosting accounts, before messing with .htaccess try this:

    Go to the Customize Permalink Structure page. Where it says "Custom, specify below" put in the following:
    /archives/%year%/%monthnum%/%day%/%postname%/

  18. avefenix1
    Member
    Posted 6 years ago #

    I put up my first blog a month ago with pretty permalinks, AOK, beautiful http://www.fredscostaricablog.com/. Now spent two days with these problems trying to put up another two of them, EXACTLY the same specs. I even copied over the good one, and it wouldn't work. Decided the only difference was the first was in the home directory of the domain, and these two were in sub-directories (on another domain). I moved one of them to the home directory on the second domain, without change. AND IT WORKED!
    That's it! I don't have time to set that all up and test it again.

Topic Closed

This topic has been closed to new replies.

About this Topic