WordPress.org

Ready to get started?Download WordPress

Forums

Problems with ISO-8859-1 + 3.1 Beta. (13 posts)

  1. M-intace
    Member
    Posted 3 years ago #

    Using the charset ISO-8859-1, WordPress deletes all text after the first accented character. A text like this, stayed that way after "unless".

  2. elfin
    Moderator
    Posted 3 years ago #

    It worked for me, could it be a database collation issue? is yours set to utf8_general_ci? if not try converting it to that and see if that helps.

  3. M-intace
    Member
    Posted 3 years ago #

    I tested with WordPress 3.0.2 and 3.1 Beta 16732, and the same error happens. Even changing the collation of the database to utf8_general_ci, the error still repeats. The error is repeated with latin1_swedish_ci collation.

  4. elfin
    Moderator
    Posted 3 years ago #

    I'll prod someone to have a look at this thread.

  5. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

    Not sure what's going on here, but if it was reproduced in 3.0.2 as well, then this isn't a 3.1 beta problem.

    Worth checking Trac for related tickets. I imagine one exists.

  6. elfin
    Moderator
    Posted 3 years ago #

    Thanks for replying- I wasn't sure about this one.

  7. M-intace
    Member
    Posted 3 years ago #

    I thought this was a problem in Beta, but he was also present in earlier versions. I'm sure this error is not PHP or MySQL.

  8. What about Mod_Rewrite?

  9. M-intace
    Member
    Posted 3 years ago #

    I think that is not a correct way to solve the problem. I prefer that this be corrected with PHP, rather than a .htacess file, what I consider a quick fix, but somehow, very bad.

  10. Er... Not mod_rewrite, I'm sorry. My brain fell out.

    mod security

    I've had hellacious problems with that killing random words in posts.

    http://wordpress.org/support/topic/disable-mod-security?replies=16

  11. M-intace
    Member
    Posted 3 years ago #

    Nothing of the kind.

  12. What does that mean?

    You don't have mod_security installed on your server?

  13. M-intace
    Member
    Posted 3 years ago #

    Though it is strange, no. Unless my httpd.conf is incorrect, anything mod_security.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.